summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authordj <dj@138bc75d-0d04-0410-961f-82ee72b054a4>2009-04-14 17:46:29 +0000
committerdj <dj@138bc75d-0d04-0410-961f-82ee72b054a4>2009-04-14 17:46:29 +0000
commit2b2c337a205c25c3e3f359d74928df1a8caa8c80 (patch)
tree9aacce9b6f0c40db559db0e9a964e64047ec0a58 /libiberty/configure.ac
parent222652cdc4a29c3ef6ec0a5504b33a6624ef672b (diff)
downloadgcc-2b2c337a205c25c3e3f359d74928df1a8caa8c80.tar.gz
* configure.ac (setobjs, msdosdjgpp): Move a-priori setting of
existing and required library functions to with_target_subdir section, so that the native build does detect them at configure time. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@146056 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac39
1 files changed, 22 insertions, 17 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index 6cfe335c687..90d60601124 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -469,6 +469,28 @@ if test -n "${with_target_subdir}"; then
setobjs=yes
;;
+ *-*-msdosdjgpp)
+ AC_LIBOBJ([vasprintf])
+ AC_LIBOBJ([vsnprintf])
+ AC_LIBOBJ([snprintf])
+ AC_LIBOBJ([asprintf])
+
+ for f in atexit basename bcmp bcopy bsearch bzero calloc clock ffs \
+ getcwd getpagesize getrusage gettimeofday \
+ index insque memchr memcmp memcpy memmove memset psignal \
+ putenv random rename rindex sbrk setenv stpcpy strcasecmp \
+ strchr strdup strerror strncasecmp strrchr strstr strtod \
+ strtol strtoul sysconf times tmpnam vfprintf vprintf \
+ vsprintf waitpid
+ do
+ n=HAVE_`echo $f | tr 'abcdefghijklmnopqrstuvwxyz' 'ABCDEFGHIJKLMNOPQRSTUVWXYZ'`
+ AC_DEFINE_UNQUOTED($n)
+ done
+
+
+ setobjs=yes
+ ;;
+
esac
# We may wish to install the target headers somewhere.
@@ -548,23 +570,6 @@ if test -z "${setobjs}"; then
setobjs=yes
;;
- *-*-msdosdjgpp)
- for f in atexit basename bcmp bcopy bsearch bzero calloc clock ffs \
- getcwd getpagesize getrusage gettimeofday \
- index insque memchr memcmp memcpy memmove memset psignal \
- putenv random rename rindex sbrk setenv stpcpy strcasecmp \
- strchr strdup strerror strncasecmp strrchr strstr strtod \
- strtol strtoul sysconf times tmpnam vfprintf vprintf \
- vsprintf waitpid
- do
- n=HAVE_`echo $f | tr 'abcdefghijklmnopqrstuvwxyz' 'ABCDEFGHIJKLMNOPQRSTUVWXYZ'`
- AC_DEFINE_UNQUOTED($n)
- done
-
-
- setobjs=yes
- ;;
-
esac
fi