summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2004-12-20 04:01:20 +0000
committerhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2004-12-20 04:01:20 +0000
commitfdf7ca85d8dda94504582387585929d04a88ae00 (patch)
tree493054be8e82cf0ab4256b3e63449e6dd366c8bf /libiberty/configure.ac
parentce6975765c7bcbf242ce3a0fc64bd54421bfa58a (diff)
downloadgcc-fdf7ca85d8dda94504582387585929d04a88ae00.tar.gz
2004-12-19 H.J. Lu <hongjiu.lu@intel.com>
PR bootstrap/19072 * Makefile.in (enable_shared): New substitute. (LTTARGETLIB): New. (PREFIXTARGETLIB): New. (LTTESTLIB): New. (PREFIXTESTLIB): New. (CCLD): New. (LINK): New. ($(TARGETLIB)): Use $(LINK) to create libraries and create targets by hand. ($(TESTLIB)): Likewise. (mostlyclean): Don't remove .libs. Remove the libtool object directory. * config.table (enable_shared): Removed. * configure.ac (enable_static): Set to yes. (AC_PROG_LIBTOOL): Removed. (AM_DISABLE_SHARED): Uncommented. (AM_PROG_LIBTOOL): Likewise. (LIBOBJS): Add `./' to avoid VPATH. (LTLIBOBJS): Likewise. (enable_shared): Substitute. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@92406 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac35
1 files changed, 29 insertions, 6 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index 9e13b5c7d37..012bbfc262c 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -4,6 +4,9 @@ AC_PREREQ(2.59)
AC_INIT
AC_CONFIG_SRCDIR([xmalloc.c])
+# FIXME: libiberty doesn't support --disable-static
+enable_static=yes
+
# This works around the fact that libtool configuration may change LD
# for this particular configuration, but some shells, instead of
# keeping the changes in LD private, export them just because LD is
@@ -113,8 +116,6 @@ GCC_NO_EXECUTABLES
AC_PROG_CC
AC_PROG_CPP_WERROR
-AC_PROG_LIBTOOL
-
if test x$GCC = xyes; then
ac_libiberty_warn_cflags='-W -Wall -Wtraditional -pedantic'
fi
@@ -124,13 +125,11 @@ AC_C_CONST
AC_C_INLINE
AC_C_BIGENDIAN_CROSS
-dnl When we start using libtool:
dnl Default to a non shared library. This may be overridden by the
dnl configure option --enable-shared.
-dnl AM_DISABLE_SHARED
+AM_DISABLE_SHARED
-dnl When we start using libtool:
-dnl AM_PROG_LIBTOOL
+AM_PROG_LIBTOOL
dnl When we start using automake:
dnl AM_CONFIG_HEADER(config.h:config.in)
@@ -529,6 +528,30 @@ else
fi
AC_SUBST(INSTALL_DEST)
+# Add `./' to avoid VPATH.
+m4_pattern_allow(LIBOBJS)
+L=""
+for l in x $LIBOBJS; do
+ case $l in
+ x) ;;
+ *) L="$L ./$l" ;;
+ esac
+done
+LIBOBJS="$L"
+
+m4_pattern_allow(LTLIBOBJS)
+L=""
+for l in x $LTLIBOBJS; do
+ case $l in
+ x) ;;
+ *) L="$L ./$l" ;;
+ esac
+done
+LTLIBOBJS="$L"
+
+dnl Delete it when we start creating shared library with libtool.
+AC_SUBST(enable_shared)
+
# We need multilib support, but only if configuring for the target.
AC_CONFIG_FILES([Makefile testsuite/Makefile])
AC_CONFIG_COMMANDS([default],