summaryrefslogtreecommitdiff
path: root/libgomp/configure.ac
diff options
context:
space:
mode:
authordfranke <dfranke@138bc75d-0d04-0410-961f-82ee72b054a4>2006-12-21 22:29:08 +0000
committerdfranke <dfranke@138bc75d-0d04-0410-961f-82ee72b054a4>2006-12-21 22:29:08 +0000
commit0ed6d01267b2aa1508dec3ed1bbfb67ad3f4dcba (patch)
tree431fe1679a89a4f2c4ce0e099c1c53dd39131c0d /libgomp/configure.ac
parentc8aaf000d90103d91d3314584c569bc0eb74467a (diff)
downloadgcc-0ed6d01267b2aa1508dec3ed1bbfb67ad3f4dcba.tar.gz
2006-12-21 Daniel Franke <franke.daniel@gmail.com>
PR libgomp/28209 * libgomp.texi: New file. * configure.ac: Add --enable-generated-files-in-srcdir option. * Makefile.am: Add info, dvi, pdf, html targets. On request, copy files to srcdir. * Makefile.in: Regenerated. * config.h.in: Regenerated. * testsuite/Makefile.in: Regenerated. * NOTES: Removed. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@120122 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgomp/configure.ac')
-rw-r--r--libgomp/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/libgomp/configure.ac b/libgomp/configure.ac
index d6f960e3833..e42faccc391 100644
--- a/libgomp/configure.ac
+++ b/libgomp/configure.ac
@@ -21,6 +21,20 @@ LIBGOMP_ENABLE(linux-futex, default, ,
permit yes|no|default)
AC_MSG_RESULT($enable_linux_futex)
+# We would like our source tree to be readonly. However when releases or
+# pre-releases are generated, the flex/bison generated files as well as the
+# various formats of manuals need to be included along with the rest of the
+# sources. Therefore we have --enable-generated-files-in-srcdir to do
+# just that.
+AC_MSG_CHECKING([for --enable-generated-files-in-srcdir])
+LIBGOMP_ENABLE(generated-files-in-srcdir, no, ,
+ [put copies of generated files in source dir intended for creating source
+ tarballs for users without texinfo bison or flex.],
+ permit yes|no)
+AC_MSG_RESULT($enable_generated_files_in_srcdir)
+AM_CONDITIONAL(GENINSRC, test "$enable_generated_files_in_srcdir" = yes)
+
+
# -------
# -------