summaryrefslogtreecommitdiff
path: root/libgomp/configure.ac
diff options
context:
space:
mode:
authorAndreas Tobler <andreast@gcc.gnu.org>2006-02-25 22:23:09 +0100
committerAndreas Tobler <andreast@gcc.gnu.org>2006-02-25 22:23:09 +0100
commitd349482e965a1f68edcc6cbac12aa52c5cc95196 (patch)
tree35e1a6bf9ec819162ff656bdf638454bf4206833 /libgomp/configure.ac
parent332cf1b33ae2722c6586249957f96d0795deab52 (diff)
downloadgcc-d349482e965a1f68edcc6cbac12aa52c5cc95196.tar.gz
[multiple changes]
2006-02-25 Shantonu Sen <ssen@opendarwin.org> * config/posix/sem.h: Define BROKEN_POSIX_SEMAPHORES functions. * config/posix/sem.c: Implement the above. 2006-02-25 Andreas Tobler <a.tobler@schweiz.ch> * configure.ac (HAVE_BROKEN_POSIX_SEMAPHORES): Check for darwin and define HAVE_BROKEN_POSIX_SEMAPHORES. * configure: Rebuilt. * config.h.in: Rebuilt. From-SVN: r111441
Diffstat (limited to 'libgomp/configure.ac')
-rw-r--r--libgomp/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/libgomp/configure.ac b/libgomp/configure.ac
index dd4faf8d145..08f67243dcd 100644
--- a/libgomp/configure.ac
+++ b/libgomp/configure.ac
@@ -164,6 +164,15 @@ AC_LINK_IFELSE(
# Check for functions needed.
AC_CHECK_FUNCS(getloadavg clock_gettime)
+# Check for broken semaphore implementation on darwin.
+# sem_init returns: sem_init error: Function not implemented.
+case "$host" in
+ *-darwin*)
+ AC_DEFINE(HAVE_BROKEN_POSIX_SEMAPHORES, 1,
+ Define if the POSIX Semaphores do not work on your system.)
+ ;;
+esac
+
# At least for glibc, clock_gettime is in librt. But don't pull that
# in if it still doesn't give us the function we want.
if test $ac_cv_func_clock_gettime = no; then