summaryrefslogtreecommitdiff
path: root/libgomp/Makefile.am
diff options
context:
space:
mode:
authorbrooks <brooks@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-02 00:03:11 +0000
committerbrooks <brooks@138bc75d-0d04-0410-961f-82ee72b054a4>2007-03-02 00:03:11 +0000
commitbdad761b36a4b09e37d2d96330df4fe20bbce092 (patch)
tree8fa3ce5b1c88c9afcec43e6fa70a7402b7dfac7d /libgomp/Makefile.am
parent0dedf8c7ce75e87ff67bb7b9131777663ae03f96 (diff)
downloadgcc-bdad761b36a4b09e37d2d96330df4fe20bbce092.tar.gz
* Makefile.am: Add install-pdf target as copied from
automake v1.10 rules. * Makefile.in: Regenerate git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@122451 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgomp/Makefile.am')
-rw-r--r--libgomp/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/libgomp/Makefile.am b/libgomp/Makefile.am
index c2bfbeaad5f..8192aec1a3c 100644
--- a/libgomp/Makefile.am
+++ b/libgomp/Makefile.am
@@ -51,10 +51,19 @@ env.lo: libgomp_f.h
env.o: libgomp_f.h
-# No install-html target
-.PHONY: install-html
+# No install-html or install-pdf support in automake yet
+.PHONY: install-html install-pdf
install-html:
+install-pdf: $(PDFS)
+ @$(NORMAL_INSTALL)
+ test -z "$(pdfdir)" || $(mkinstalldirs) "$(DESTDIR)$(pdfdir)"
+ @list='$(PDFS)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(am__strip_dir) \
+ echo " $(INSTALL_DATA) '$$d$$p' '$(DESTDIR)$(pdfdir)/$$f'"; \
+ $(INSTALL_DATA) "$$d$$p" "$(DESTDIR)$(pdfdir)/$$f"; \
+ done
# Automake Documentation:
# If your package has Texinfo files in many directories, you can use the