summaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-01-06 19:24:23 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-01-06 19:24:23 +0000
commit275f094b185194ce00edc86f084b27fc6be2cc61 (patch)
tree23b882305679e1e26e46b19513733540100b19e7 /libgo/configure.ac
parent6685d11ca873e7e78314597a48e934e13946b5af (diff)
downloadgcc-275f094b185194ce00edc86f084b27fc6be2cc61.tar.gz
go/build: Set GOARCH on arm64 systems.
I am reliably informed that the architecture name and letter for the plan9/inferno compilers for 64-bit ARM systems will be "arm64" and "7" respectively, so let's get that bit in nice and early. From Michael Hudson-Doyle. https://codereview.appspot.com/34830045/ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@206374 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index b43a1580749..dc1f9082a0a 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -174,6 +174,7 @@ dnl N.B. Keep in sync with gcc/testsuite/go.test/go-test.exp (go-set-goarch).
is_386=no
is_alpha=no
is_arm=no
+is_arm64=no
is_m68k=no
mips_abi=unknown
is_ppc=no
@@ -187,6 +188,10 @@ case ${host} in
is_alpha=yes
GOARCH=alpha
;;
+ aarch64-*-*)
+ is_arm64=yes
+ GOARCH=arm64
+ ;;
arm*-*-* | strongarm*-*-* | ep9312*-*-* | xscale-*-*)
is_arm=yes
GOARCH=arm
@@ -267,6 +272,7 @@ esac
AM_CONDITIONAL(LIBGO_IS_386, test $is_386 = yes)
AM_CONDITIONAL(LIBGO_IS_ALPHA, test $is_alpha = yes)
AM_CONDITIONAL(LIBGO_IS_ARM, test $is_arm = yes)
+AM_CONDITIONAL(LIBGO_IS_ARM64, test $is_arm64 = yes)
AM_CONDITIONAL(LIBGO_IS_M68K, test $is_m68k = yes)
AM_CONDITIONAL(LIBGO_IS_MIPS, test $mips_abi != unknown)
AM_CONDITIONAL(LIBGO_IS_MIPSO32, test $mips_abi = o32)