summaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2017-06-21 21:55:34 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2017-06-21 21:55:34 +0000
commit074bbd7b6a221b0446c73b3f4c2e1bf6cc7b2634 (patch)
tree7a9a252656a6c44d62299c3feec2c5c9bb7377db /libgo/configure.ac
parent10d1901b6cea049e47001e41dcfc7a33a3cf880c (diff)
downloadgcc-074bbd7b6a221b0446c73b3f4c2e1bf6cc7b2634.tar.gz
libgo: use gc's arch names as the default GOARCHs on MIPS
This means that the gc tools and gofrontend agree on the architecture names for the 3 MIPS ABIs which should allow a gofrontend compiler to build go. Reviewed-on: https://go-review.googlesource.com/46153 git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@249476 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index d16547f4487..bded202fea2 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -299,9 +299,9 @@ GOARCH_HUGEPAGESIZE="1 << 21"
[AC_MSG_ERROR([unknown MIPS ABI])
[mips_abi="n32"]])])])])
case "$mips_abi" in
- "o32") GOARCH=mipso32 ;;
- "n32") GOARCH=mipsn32 ;;
- "n64") GOARCH=mipsn64 ;;
+ "o32") GOARCH=mips ;;
+ "n32") GOARCH=mips64p32 ;;
+ "n64") GOARCH=mips64 ;;
"o64") GOARCH=mipso64 ;;
esac
case "$mips_abi" in
@@ -315,7 +315,8 @@ GOARCH_HUGEPAGESIZE="1 << 21"
;;
esac
case "${host}" in
- mips*el)
+ mips*el-*-*)
+ GOARCH="${GOARCH}le"
;;
*)
GOARCH_BIGENDIAN=1