summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-31 23:55:21 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-31 23:55:21 +0000
commit524b52f80ebabad69b05ce767f90001576b869b1 (patch)
tree12ffe01ea1bf061534d99f4b1731e48f6d17f424 /libgo/Makefile.am
parent0be16c20b1c2b93943d0f97af985d818a4e66ffb (diff)
downloadgcc-524b52f80ebabad69b05ce767f90001576b869b1.tar.gz
PR go/47515
libgo: Add Irix support. From Rainer Orth. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@171806 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index cf6975d2db9..f87494cac01 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -709,6 +709,9 @@ else
if LIBGO_IS_SOLARIS
go_os_sys_file = go/os/sys_uname.go
else
+if LIBGO_IS_IRIX
+go_os_sys_file = go/os/sys_uname.go
+else
if LIBGO_IS_RTEMS
go_os_sys_file = go/os/sys_uname.go
else
@@ -716,6 +719,7 @@ go_os_sys_file = go/os/sys_bsd.go
endif
endif
endif
+endif
go_os_files = \
$(go_os_dir_file) \