summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2012-07-26 01:57:04 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2012-07-26 01:57:04 +0000
commitb9976017d25543a587f155ae05044ca7acec2bc5 (patch)
tree327ba5fd7f5170e2e9e56e5a3503f6a733ffaed4 /libgo/Makefile.am
parenteb9f349aaf87e84d270b24e9f39b8d2230c965a1 (diff)
downloadgcc-b9976017d25543a587f155ae05044ca7acec2bc5.tar.gz
runtime, runtime/pprof: Fix runtime/pprof test to pass, enable it.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@189878 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 7923567e978..f59b0048495 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -1794,7 +1794,7 @@ GOTESTFLAGS =
# Check a package.
CHECK = \
- GC="$(GOC) $(GOCFLAGS) -L `${PWD_COMMAND}` -L `${PWD_COMMAND}`/.libs"; \
+ GC="$(GOC) $(GOCFLAGS) $($(subst /,_,$@)_GOCFLAGS) -L `${PWD_COMMAND}` -L `${PWD_COMMAND}`/.libs"; \
export GC; \
GOLIBS="$(MATH_LIBS) $(NET_LIBS)"; \
export GOLIBS; \
@@ -3012,6 +3012,9 @@ runtime/pprof.lo: $(go_runtime_pprof_files)
runtime/pprof/check: $(CHECK_DEPS)
@$(CHECK)
.PHONY: runtime/pprof/check
+# At least for now, we need -static-libgo for this test, because
+# otherwise we can't get the line numbers.
+runtime_pprof_check_GOCFLAGS = -static-libgo
@go_include@ sync/atomic.lo.dep
sync/atomic.lo.dep: $(go_sync_atomic_files)
@@ -3548,6 +3551,7 @@ TEST_PACKAGES = \
os/user/check \
path/filepath/check \
regexp/syntax/check \
+ runtime/pprof/check \
sync/atomic/check \
text/scanner/check \
text/tabwriter/check \