summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2013-02-05 22:22:17 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2013-02-05 22:22:17 +0000
commit6222f4a828548c0188ede626ded81d1f307803cc (patch)
tree41af694846a1bfc8719f9e3c0aeb2200cceb969f /libgo/Makefile.am
parent4f364235dcb67b1953b21be78391110b4c633e1b (diff)
downloadgcc-6222f4a828548c0188ede626ded81d1f307803cc.tar.gz
PR go/56017
libgo: Use DejaGNU when testing a cross-compiler. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@195766 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index f68443cb5a2..4ba3145daab 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -1991,12 +1991,6 @@ BUILDPACKAGE = \
files=`echo $^ | sed -e 's/[^ ]*\.gox//g'`; \
$(LTGOCOMPILE) -I . -c -fgo-pkgpath=`echo $@ | sed -e 's/.lo$$//' -e 's/-go$$//'` -o $@ $$files
-if LIBGO_IS_RTEMS
-use_dejagnu = yes
-else
-use_dejagnu = no
-endif
-
GOTESTFLAGS =
# Check a package.
@@ -2015,7 +2009,7 @@ CHECK = \
export LD_LIBRARY_PATH; \
$(MKDIR_P) $(@D); \
rm -f $@-testsum $@-testlog; \
- if test "$(use_dejagnu)" = "yes"; then \
+ if test "$(USE_DEJAGNU)" = "yes"; then \
$(SHELL) $(srcdir)/testsuite/gotest --dejagnu=yes --basedir=$(srcdir) --srcdir=$(srcdir)/go/$(@D) --pkgpath="$(@D)" --pkgfiles="$(go_$(subst /,_,$(@D))_files)" --testname="$(@D)" --goarch="$(GOARCH)" $(GOTESTFLAGS) $(go_$(subst /,_,$(@D))_test_files); \
else \
if $(SHELL) $(srcdir)/testsuite/gotest --basedir=$(srcdir) --srcdir=$(srcdir)/go/$(@D) --pkgpath="$(@D)" --pkgfiles="$(go_$(subst /,_,$(@D))_files)" --goarch="$(GOARCH)" $(GOTESTFLAGS) $(go_$(subst /,_,$(@D))_test_files) >>$@-testlog 2>&1; then \