summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-01-08 01:08:29 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-01-08 01:08:29 +0000
commitb5656ca95fff3a517f00ee2297d78706e1810957 (patch)
tree64ded3dc2ea89ef1e27d4a84653a9306f1dcfe05 /libgo/Makefile.am
parent85e1c970f2786aeff4220c4990d61a7576de80a1 (diff)
downloadgcc-b5656ca95fff3a517f00ee2297d78706e1810957.tar.gz
PR go/59430
os/user: Use POSIX functions on Solaris. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@206412 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 0851b71e02e..4f09bc30bf6 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -1465,10 +1465,17 @@ go_os_signal_files = \
go/os/signal/signal.go \
go/os/signal/signal_unix.go
+if LIBGO_IS_SOLARIS
+os_user_decls_file = go/os/user/decls_solaris.go
+else
+os_user_decls_file = go/os/user/decls_unix.go
+endif
+
go_os_user_files = \
- go/os/user/user.go \
go/os/user/lookup.go \
- go/os/user/lookup_unix.go
+ go/os/user/lookup_unix.go \
+ go/os/user/user.go \
+ $(os_user_decls_file)
go_path_filepath_files = \
go/path/filepath/match.go \