summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorsayle <sayle@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-16 22:03:14 +0000
committersayle <sayle@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-16 22:03:14 +0000
commit4d63144219095eef351fad21267e78be8433740b (patch)
tree84f146ec71a8d94adcbaa82b061c8a23118009fb /libgfortran/configure.ac
parent6c24ebbec2bc2a291e8a710317b8b8cc4a32fdb9 (diff)
downloadgcc-4d63144219095eef351fad21267e78be8433740b.tar.gz
* configure.ac (CFLAGS): Update to include -std=gnu99 so that
the configure tests will be run with the same environment as used to compile the libgfortran source code. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@109774 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 7d549744435..e01d7128bc4 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -116,6 +116,9 @@ if test "x$GCC" = "xyes"; then
## We like to use C99 routines when available. This makes sure that
## __STDC_VERSION__ is set such that libc includes make them available.
AM_CFLAGS="-std=gnu99 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wextra -Wwrite-strings"
+ ## Compile the following tests with the same system header contents
+ ## that we'll encounter when compiling our own source files.
+ CFLAGS="-std=gnu99 $CFLAGS"
fi
AC_SUBST(AM_FCFLAGS)
AC_SUBST(AM_CFLAGS)