summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authoraj <aj@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-15 15:37:18 +0000
committeraj <aj@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-15 15:37:18 +0000
commit09e5829fd4031fb5e82eb1d74174e5054a487d28 (patch)
tree86a911fd57b949150311c11e562e0608b3efc89c /libgfortran/configure.ac
parentd5142e57e2c79ae7f28ae7b2a6dda2ad18dc5d69 (diff)
downloadgcc-09e5829fd4031fb5e82eb1d74174e5054a487d28.tar.gz
* intrinsics/pack_generic.c (pack): Remove unneeded calculation.
* m4/matmull.m4 (matmul_): Remove unneeded calculations, fix pointer cast to avoid warning. * generated/matmul_l4.c: Regenerated. * generated/matmul_l8.c: Regenerated. * Makefile.am: Remove AM_CFLAGS here. * configure.ac: Define AM_CFLAGS and AM_FCFLAGS so that warnings are set. Set additionally -Wstrict-prototypes for CFLAGS. * Makefile.in: Regenerated * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@99723 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 4a248855dd2..b372a7b2a1a 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -109,12 +109,15 @@ m4_define([_AC_ARG_VAR_PRECIOUS],[])
AC_PROG_CC
m4_rename([real_PRECIOUS],[_AC_ARG_VAR_PRECIOUS])
-AC_SUBST(CFLAGS)
-
# Add -Wall if we are using GCC.
if test "x$GCC" = "xyes"; then
- CFLAGS="$CFLAGS -Wall"
+ AM_FCFLAGS="-Wall"
+ ## We like to use C99 routines when available. This makes sure that
+ ## __STDC_VERSION__ is set such that libc includes make them available.
+ AM_CFLAGS="-std=gnu99 -Wall -Wstrict-prototypes"
fi
+AC_SUBST(AM_FCFLAGS)
+AC_SUBST(AM_CFLAGS)
# Find other programs we need.
AC_CHECK_TOOL(AS, as)