summaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorpbrook <pbrook@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-12 17:59:30 +0000
committerpbrook <pbrook@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-12 17:59:30 +0000
commita31bd8a4ae47473ca1985ac4c21d44ce3426aba9 (patch)
treefd31ff0dfbe883550455e1ab011a7e5daacf1f23 /libgfortran/configure.ac
parent041de113d1e6528521460bdef4687fa6cfae24c9 (diff)
downloadgcc-a31bd8a4ae47473ca1985ac4c21d44ce3426aba9.tar.gz
PR gfortran/15292
* intrinsics/c99_functions.c: New file. * Makefile.am: Add new file. * configure.ac: Added test for round/roundf. * Makefile.in: Regenerate. * configure: Regenerate. * configure.h.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@83036 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 9a719d95155..d4278569134 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -166,6 +166,10 @@ AC_CHECK_LIB([mx],[csin],[need_math="no"],[need_math="yes"])
# Check for library functions.
AC_CHECK_FUNCS(getrusage times)
+# Check for some C99 functions
+AC_CHECK_LIB([m],[round],[AC_DEFINE([HAVE_ROUND],[1],["c99 function"])])
+AC_CHECK_LIB([m],[roundf],[AC_DEFINE([HAVE_ROUNDF],[1],["c99 function"])])
+
# Let the user override this
AC_ARG_ENABLE(cmath,
AC_HELP_STRING([--enable-cmath],[Include complex math functions]),