summaryrefslogtreecommitdiff
path: root/libgfortran/Makefile.am
diff options
context:
space:
mode:
authorRichard Henderson <rth@redhat.com>2004-12-06 13:29:57 -0800
committerRichard Henderson <rth@gcc.gnu.org>2004-12-06 13:29:57 -0800
commita8bc7089b572f674c128deaaf0106399bf0ff797 (patch)
tree149d5ce12b07a2bd72875a8d995d53551613b3eb /libgfortran/Makefile.am
parent63bb59a32cd54454a3ece47024f81d2c7d313a27 (diff)
downloadgcc-a8bc7089b572f674c128deaaf0106399bf0ff797.tar.gz
Makefile.am: Generate all m4 output under $(srcdir).
* Makefile.am: Generate all m4 output under $(srcdir). * Makefile.in: Regenerate. From-SVN: r91788
Diffstat (limited to 'libgfortran/Makefile.am')
-rw-r--r--libgfortran/Makefile.am69
1 files changed, 34 insertions, 35 deletions
diff --git a/libgfortran/Makefile.am b/libgfortran/Makefile.am
index 14bc09047d0..d1cfd6808d4 100644
--- a/libgfortran/Makefile.am
+++ b/libgfortran/Makefile.am
@@ -408,108 +408,107 @@ selected_real_kind.inc: $(srcdir)/mk-srk-inc.sh
if MAINTAINER_MODE
$(i_all_c): m4/all.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 all.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 all.m4 > $(srcdir)/$@
$(i_any_c): m4/any.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 any.m4> $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 any.m4> $(srcdir)/$@
$(i_count_c): m4/count.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 count.m4> $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 count.m4> $(srcdir)/$@
$(i_maxloc0_c): m4/maxloc0.m4 $(I_M4_DEPS0)
- m4 -Dfile=$@ -I$(srcdir)/m4 maxloc0.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 maxloc0.m4 > $(srcdir)/$@
$(i_maxloc1_c): m4/maxloc1.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 maxloc1.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 maxloc1.m4 > $(srcdir)/$@
$(i_maxval_c): m4/maxval.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 maxval.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 maxval.m4 > $(srcdir)/$@
$(i_minloc0_c): m4/minloc0.m4 $(I_M4_DEPS0)
- m4 -Dfile=$@ -I$(srcdir)/m4 minloc0.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 minloc0.m4 > $(srcdir)/$@
$(i_minloc1_c): m4/minloc1.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 minloc1.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 minloc1.m4 > $(srcdir)/$@
$(i_minval_c): m4/minval.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 minval.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 minval.m4 > $(srcdir)/$@
$(i_product_c): m4/product.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 product.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 product.m4 > $(srcdir)/$@
$(i_sum_c): m4/sum.m4 $(I_M4_DEPS1)
- m4 -Dfile=$@ -I$(srcdir)/m4 sum.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 sum.m4 > $(srcdir)/$@
$(i_dotprod_c): m4/dotprod.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 dotprod.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 dotprod.m4 > $(srcdir)/$@
$(i_dotprodl_c): m4/dotprodl.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 dotprodl.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 dotprodl.m4 > $(srcdir)/$@
$(i_dotprodc_c): m4/dotprodc.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 dotprodc.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 dotprodc.m4 > $(srcdir)/$@
$(i_matmul_c): m4/matmul.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 matmul.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 matmul.m4 > $(srcdir)/$@
$(i_matmull_c): m4/matmull.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 matmull.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 matmull.m4 > $(srcdir)/$@
$(i_transpose_c): m4/transpose.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 transpose.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 transpose.m4 > $(srcdir)/$@
$(i_shape_c): m4/shape.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 shape.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 shape.m4 > $(srcdir)/$@
$(i_reshape_c): m4/reshape.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 reshape.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 reshape.m4 > $(srcdir)/$@
$(i_eoshift1_c): m4/eoshift1.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 eoshift1.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 eoshift1.m4 > $(srcdir)/$@
$(i_eoshift3_c): m4/eoshift3.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 eoshift3.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 eoshift3.m4 > $(srcdir)/$@
$(i_cshift1_c): m4/cshift1.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 cshift1.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 cshift1.m4 > $(srcdir)/$@
$(in_pack_c): m4/in_pack.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 in_pack.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 in_pack.m4 > $(srcdir)/$@
$(in_unpack_c): m4/in_unpack.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 in_unpack.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 in_unpack.m4 > $(srcdir)/$@
$(i_exponent_c): m4/exponent.m4 m4/mtype.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 exponent.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 exponent.m4 > $(srcdir)/$@
$(i_fraction_c): m4/fraction.m4 m4/mtype.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 fraction.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 fraction.m4 > $(srcdir)/$@
$(i_nearest_c): m4/nearest.m4 m4/mtype.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 nearest.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 nearest.m4 > $(srcdir)/$@
$(i_set_exponent_c): m4/set_exponent.m4 m4/mtype.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 set_exponent.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 set_exponent.m4 > $(srcdir)/$@
$(i_pow_c): m4/pow.m4 $(I_M4_DEPS)
- m4 -Dfile=$@ -I$(srcdir)/m4 pow.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 pow.m4 > $(srcdir)/$@
$(gfor_math_trig_c): m4/ctrig.m4 m4/mtype.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 ctrig.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 ctrig.m4 > $(srcdir)/$@
$(gfor_math_exp_c): m4/cexp.m4 m4/mtype.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 cexp.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 cexp.m4 > $(srcdir)/$@
$(gfor_math_hyp_c): m4/chyp.m4 m4/mtype.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 chyp.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 chyp.m4 > $(srcdir)/$@
$(gfor_built_specific_src): m4/specific.m4 m4/head.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 specific.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 specific.m4 > $(srcdir)/$@
$(gfor_built_specific2_src): m4/specific2.m4 m4/head.m4
- m4 -Dfile=$@ -I$(srcdir)/m4 specific2.m4 > $@
+ m4 -Dfile=$@ -I$(srcdir)/m4 specific2.m4 > $(srcdir)/$@
## end of maintainer mode only rules
endif
EXTRA_DIST = $(m4_files)
-