summaryrefslogtreecommitdiff
path: root/libgcc/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2010-09-28 00:07:12 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2010-09-28 00:07:12 +0000
commitc9b3ebc566aa3daf9c5d1b7c86f0bf2fd4dbdbb0 (patch)
treeabe9b70798228d019e6509efb68de44278c0e201 /libgcc/configure.ac
parent2375c63d24a10083bf96a66beb190b80e0e0db06 (diff)
downloadgcc-c9b3ebc566aa3daf9c5d1b7c86f0bf2fd4dbdbb0.tar.gz
gcc/:
* config/i386/i386.c (ix86_supports_split_stack): -fsplit-stack requires assembler support for CFI directives. libgcc/: * configure.ac: Test whether assembler supports CFI directives. * config.host: Only add t-stack and i386/t-stack-i386 to tmake_file if libgcc_cv_cfi is "yes". * configure: Rebuild. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@164671 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgcc/configure.ac')
-rw-r--r--libgcc/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libgcc/configure.ac b/libgcc/configure.ac
index 60766371d3a..6bb4844b882 100644
--- a/libgcc/configure.ac
+++ b/libgcc/configure.ac
@@ -135,6 +135,12 @@ AC_CACHE_CHECK([whether fixed-point is supported], [libgcc_cv_fixed_point],
fixed_point=$libgcc_cv_fixed_point
AC_SUBST(fixed_point)
+# Check for assembler CFI support.
+AC_CACHE_CHECK([whether assembler supports CFI directives], [libgcc_cv_cfi],
+ [AC_COMPILE_IFELSE([int i = __GCC_HAVE_DWARF2_CFI_ASM;],
+ [libgcc_cv_cfi=yes],
+ [libgcc_cv_cfi=no])])
+
# Check 32bit or 64bit for x86.
case ${host} in
i?86*-*-* | x86_64*-*-*)