summaryrefslogtreecommitdiff
path: root/libgcc/configure.ac
diff options
context:
space:
mode:
authorchaoyingfu <chaoyingfu@138bc75d-0d04-0410-961f-82ee72b054a4>2007-09-17 22:18:13 +0000
committerchaoyingfu <chaoyingfu@138bc75d-0d04-0410-961f-82ee72b054a4>2007-09-17 22:18:13 +0000
commit3ac0842f29dd05e1265377108335ac5e7c1b0692 (patch)
treeb78141d7b773b125dccacd9b26b68b4b0ab15643 /libgcc/configure.ac
parent10535d4fe914db82b9e8b32b5e2daa289bf629ee (diff)
downloadgcc-3ac0842f29dd05e1265377108335ac5e7c1b0692.tar.gz
* fixed-obj.mk: New file to support fine-grain fixed-point functions.
* Makefile.in (fixed_point): Define. Check if fixed_point is yes to build support functions. * configure.ac: Check for fixed_point support. * configure: Regenerated. * gen-fixed.sh: New file to generate lists of fixed-point labels, funcs, modes, from, to. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@128557 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgcc/configure.ac')
-rw-r--r--libgcc/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/libgcc/configure.ac b/libgcc/configure.ac
index 0a8d235a744..6ab7ebf3948 100644
--- a/libgcc/configure.ac
+++ b/libgcc/configure.ac
@@ -145,6 +145,13 @@ if test x$enable_decimal_float = xyes; then
fi
AC_SUBST(enable_decimal_float)
+# Check for fixed-point support.
+AC_CACHE_CHECK([whether fixed-point is supported], [libgcc_cv_fixed_point],
+ [AC_COMPILE_IFELSE([_Sat _Fract x;], [libgcc_cv_fixed_point=yes],
+ [libgcc_cv_fixed_point=no])])
+fixed_point=$libgcc_cv_fixed_point
+AC_SUBST(fixed_point)
+
# Collect host-machine-specific information.
. ${srcdir}/config.host