summaryrefslogtreecommitdiff
path: root/libgcc/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl@gcc.gnu.org>2007-07-06 07:00:46 -0700
committerH.J. Lu <hjl@gcc.gnu.org>2007-07-06 07:00:46 -0700
commit6f461e76da5ea2b94ec1f8a9283ca1e2779a5cb0 (patch)
tree41af967850b0489a1585cb2751cc5c75b0cb21a3 /libgcc/configure.ac
parent374d961c0df2af3d7fc3367d63daec408b09d148 (diff)
downloadgcc-6f461e76da5ea2b94ec1f8a9283ca1e2779a5cb0.tar.gz
tls.m4 (GCC_CHECK_CC_TLS): New.
config/ 2007-07-06 H.J. Lu <hongjiu.lu@intel.com> * tls.m4 (GCC_CHECK_CC_TLS): New. libgcc/ 2007-07-06 H.J. Lu <hongjiu.lu@intel.com> * config.host (tmake_file): Add t-tls for i[34567]86-*-linux* and x86_64-*-linux*. * config/t-tls: New file. * Makefile.in (INTERNAL_CFLAGS): Add @set_have_cc_tls@. * configure.ac: Include ../config/enable.m4 and ../config/tls.m4. Use GCC_CHECK_CC_TLS to check if assembler supports TLS and substitute set_have_cc_tls. * configure: Regenerated. libbid/ 2007-07-06 H.J. Lu <hongjiu.lu@intel.com> Updated from Intel BID library: * bid_conf.h (BID_THREAD): Defined only if both HAVE_CC_TLS and USE_TLS are defined. From-SVN: r126416
Diffstat (limited to 'libgcc/configure.ac')
-rw-r--r--libgcc/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/libgcc/configure.ac b/libgcc/configure.ac
index 1187d74cc4a..1bf3644aace 100644
--- a/libgcc/configure.ac
+++ b/libgcc/configure.ac
@@ -1,5 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
+sinclude(../config/enable.m4)
+sinclude(../config/tls.m4)
sinclude(../config/acx.m4)
sinclude(../config/no-executables.m4)
@@ -167,6 +169,17 @@ else
fi
AC_SUBST(vis_hide)
+# See if we have thread-local storage. We can only test assembler
+# sicne link-time and run-time tests require the newly built
+# gcc, which can't be used to build executable due to that libgcc
+# is yet to be built here.
+GCC_CHECK_CC_TLS
+set_have_cc_tls
+if test "$enable_tls $have_cc_tls" = "yes yes"; then
+ set_have_cc_tls="-DHAVE_CC_TLS"
+fi
+AC_SUBST(set_have_cc_tls)
+
# Conditionalize the makefile for this target machine.
tmake_file_=
for f in ${tmake_file}