summaryrefslogtreecommitdiff
path: root/libffi/configure.ac
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-15 19:36:26 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-15 19:36:26 +0000
commit5ed988d23c7fd71edc010e7b6d9fbbbee2dbf87e (patch)
treeb08b4948d80791b0d6ae7cf89ddff136424373b8 /libffi/configure.ac
parentc29d64f7032233914e3f5e48ac690e3a96ba9acc (diff)
downloadgcc-5ed988d23c7fd71edc010e7b6d9fbbbee2dbf87e.tar.gz
* configure.ac (libffi_cv_as_x86_64_unwind_section_type): New test.
* configure: Regenerate. * fficonfig.h.in: Regenerate. * libffi/src/x86/unix64.S (.eh_frame) [HAVE_AS_X86_64_UNWIND_SECTION_TYPE]: Use @unwind section type. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@157466 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index c0e0da16507..1b484f94bde 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -284,6 +284,21 @@ case "$target" in
;;
esac
+if test x$TARGET = xX86_64; then
+ AC_CACHE_CHECK([assembler supports unwind section type],
+ libffi_cv_as_x86_64_unwind_section_type, [
+ libffi_cv_as_x86_64_unwind_section_type=yes
+ echo '.section .eh_frame,"a",@unwind' > conftest.s
+ if $CC $CFLAGS -c conftest.s 2>&1 | grep -i warning > /dev/null; then
+ libffi_cv_as_x86_64_unwind_section_type=no
+ fi
+ ])
+ if test "x$libffi_cv_as_x86_64_unwind_section_type" = xyes; then
+ AC_DEFINE(HAVE_AS_X86_64_UNWIND_SECTION_TYPE, 1,
+ [Define if your assembler supports unwind section type.])
+ fi
+fi
+
AC_CACHE_CHECK([whether .eh_frame section should be read-only],
libffi_cv_ro_eh_frame, [
libffi_cv_ro_eh_frame=no