summaryrefslogtreecommitdiff
path: root/libffi/configure.ac
diff options
context:
space:
mode:
authordavek <davek@138bc75d-0d04-0410-961f-82ee72b054a4>2009-05-22 16:22:53 +0000
committerdavek <davek@138bc75d-0d04-0410-961f-82ee72b054a4>2009-05-22 16:22:53 +0000
commit1cde303dc7c9f6c64d2331983add3f0d1159b925 (patch)
treef8970032a5fabd58011412456344d32254bece0f /libffi/configure.ac
parentaed4eb5dbf4e314cd58c8ab4aa7115029d5415e0 (diff)
downloadgcc-1cde303dc7c9f6c64d2331983add3f0d1159b925.tar.gz
* configure.ac: Also check if assembler supports pc-relative
relocs on X86_WIN32 targets. * configure: Regenerate. * src/x86/win32.S (ffi_prep_args): Declare extern, not global. (_ffi_call_SYSV): Add missing function type symbol .def and add EH markup labels. (_ffi_call_STDCALL): Likewise. (_ffi_closure_SYSV): Likewise. (_ffi_closure_raw_SYSV): Likewise. (.eh_frame): Add hand-crafted EH data. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@147800 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index 2dff35c060f..a9f8e519fed 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -240,7 +240,7 @@ if test x$TARGET = xSPARC; then
fi
fi
-if test x$TARGET = xX86 || test x$TARGET = xX86_64; then
+if test x$TARGET = xX86 || test x$TARGET = xX86_WIN32 || test x$TARGET = xX86_64; then
AC_CACHE_CHECK([assembler supports pc related relocs],
libffi_cv_as_x86_pcrel, [
libffi_cv_as_x86_pcrel=yes