summaryrefslogtreecommitdiff
path: root/libffi/configure.ac
diff options
context:
space:
mode:
authordaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2007-08-10 15:35:55 +0000
committerdaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2007-08-10 15:35:55 +0000
commitedd57a0a515a6c0c9f24be07ffee4b418154787d (patch)
tree7f34b10176eedc697f1ada58dd6a727f07371578 /libffi/configure.ac
parentab0ab0a663c7da512b277a99ffa21f51ee659d8e (diff)
downloadgcc-edd57a0a515a6c0c9f24be07ffee4b418154787d.tar.gz
PR libffi/28313
* configure.ac: Don't treat mips64 as a special case. * Makefile.am (nodist_libffi_la_SOURCES): Add n32.S. * configure: Regenerate * Makefile.in: Ditto. * fficonfig.h.in: Ditto. * src/mips/ffitarget.h (REG_L, REG_S, SUBU, ADDU, SRL, LI): Indent. (LA, EH_FRAME_ALIGN, FDE_ADDR_BYTES): New preprocessor macros. (FFI_DEFAULT_ABI): Set for n64 case. (FFI_CLOSURES, FFI_TRAMPOLINE_SIZE): Define for n32 and n64 cases. * src/mips/n32.S (ffi_call_N32): Add debug macros and labels for FDE. (ffi_closure_N32): New function. (.eh_frame): New section * src/mips/o32.S: Clean up comments. (ffi_closure_O32): Pass ffi_closure parameter in $12. * src/mips/ffi.c: Use FFI_MIPS_N32 instead of _MIPS_SIM == _ABIN32 throughout. (FFI_MIPS_STOP_HERE): New, use in place of ffi_stop_here. (ffi_prep_args): Use unsigned long to hold pointer values. Rewrite to support n32/n64 ABIs. (calc_n32_struct_flags): Rewrite. (calc_n32_return_struct_flags): Remove unused variable. Reverse position of flag bits. (ffi_prep_cif_machdep): Rewrite n32 portion. (ffi_call): Enable for n64. Add special handling for small structure return values. (ffi_prep_closure_loc): Add n32 and n64 support. (ffi_closure_mips_inner_O32): Add cast to silence warning. (copy_struct_N32, ffi_closure_mips_inner_N32): New functions. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@127336 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index 6c7a9d26969..e47013f39ab 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -94,8 +94,6 @@ case "$host" in
TARGET=M68K; TARGETDIR=m68k
;;
- mips64*-*)
- ;;
mips-sgi-irix5.* | mips-sgi-irix6.*)
TARGET=MIPS_IRIX; TARGETDIR=mips
;;