summaryrefslogtreecommitdiff
path: root/libffi/configure.ac
diff options
context:
space:
mode:
authorkcook <kcook@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-18 01:49:43 +0000
committerkcook <kcook@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-18 01:49:43 +0000
commit69738b31c804758802eea2d2791e51d8ed6df6d9 (patch)
tree93288870ffb704b27298ee841ea2c448f3e1bc3a /libffi/configure.ac
parent3b246ee965f37c0178454f5ca308cdb31656c17f (diff)
downloadgcc-69738b31c804758802eea2d2791e51d8ed6df6d9.tar.gz
2005-05-03 Kelley Cook <kcook@gcc.gnu.org>
* configure.ac: Use AC_C_BIGENDIAN instead of AC_C_BIGENDIAN_CROSS. Use AC_CHECK_SIZEOF instead of AC_COMPILE_CHECK_SIZEOF. * Makefile.am (ACLOCAL_AMFLAGS): Remove -I ../config. * aclocal.m4, configure, fficonfig.h.in, Makefile.in, include/Makefile.in, testsuite/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@99879 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index 6d171608211..b0bfd4991dc 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -118,8 +118,8 @@ AC_HEADER_STDC
AC_CHECK_FUNCS(memcpy)
AC_FUNC_ALLOCA
-AC_COMPILE_CHECK_SIZEOF(double)
-AC_COMPILE_CHECK_SIZEOF(long double)
+AC_CHECK_SIZEOF(double)
+AC_CHECK_SIZEOF(long double)
# Also AC_SUBST this variable for ffi.h.
HAVE_LONG_DOUBLE=0
@@ -131,7 +131,7 @@ if test $ac_cv_sizeof_double != $ac_cv_sizeof_long_double; then
fi
AC_SUBST(HAVE_LONG_DOUBLE)
-AC_C_BIGENDIAN_CROSS
+AC_C_BIGENDIAN
if test x$TARGET = xSPARC; then
AC_CACHE_CHECK([assembler and linker support unaligned pc related relocs],