summaryrefslogtreecommitdiff
path: root/libffi/configure.ac
diff options
context:
space:
mode:
authorgreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2009-12-31 17:44:32 +0000
committergreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2009-12-31 17:44:32 +0000
commit1a42df5da1c35e75c4ca2e5baa55c06246966599 (patch)
tree413bf962b43b4c0fe1180b5401b187f3dcb74d07 /libffi/configure.ac
parent8539c541b27144e2f1380d7ea9a7214b221fabab (diff)
downloadgcc-1a42df5da1c35e75c4ca2e5baa55c06246966599.tar.gz
Windows patch
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@155540 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index f101f494177..a3988395bcc 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -2,7 +2,7 @@ dnl Process this with autoconf to create configure
AC_PREREQ(2.64)
-AC_INIT([libffi], [3.0.8], [http://gcc.gnu.org/bugs.html])
+AC_INIT([libffi], [3.0.9], [http://gcc.gnu.org/bugs.html])
AC_CONFIG_HEADERS([fficonfig.h])
AM_ENABLE_MULTILIB(, ..)
@@ -82,6 +82,8 @@ case "$host" in
;;
i?86-win32* | i?86-*-cygwin* | i?86-*-mingw*)
TARGET=X86_WIN32; TARGETDIR=x86
+ # All mingw/cygwin/win32 builds require this for sharedlib
+ AM_LTLDFLAGS="-no-undefined"
;;
i?86-*-darwin*)
TARGET=X86_DARWIN; TARGETDIR=x86
@@ -160,6 +162,7 @@ case "$host" in
esac
AC_SUBST(AM_RUNTESTFLAGS)
+AC_SUBST(AM_LTLDFLAGS)
if test $TARGETDIR = unknown; then
AC_MSG_ERROR(["libffi has not been ported to $host."])