summaryrefslogtreecommitdiff
path: root/libffi/configure.ac
diff options
context:
space:
mode:
authorandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2009-12-26 18:49:55 +0000
committerandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2009-12-26 18:49:55 +0000
commit3531d81fc96e1a056686527aafe18cf934ce6d44 (patch)
tree1662bd43280fd0c940233f8e229b9a2eaec7361e /libffi/configure.ac
parent81b376aefe496a92f695ce84f8a7271a9bcee8c1 (diff)
downloadgcc-3531d81fc96e1a056686527aafe18cf934ce6d44.tar.gz
2009-12-26 Andreas Tobler <a.tobler@schweiz.org>
* configure.ac: Define FFI_MMAP_EXEC_WRIT for the given targets. * configure: Regenerate. * fficonfig.h.in: Likewise. * src/closures.c: Remove the FFI_MMAP_EXEC_WRIT definition for Solaris/x86. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@155475 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index a1a016cf082..f101f494177 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -271,6 +271,14 @@ if test x$TARGET = xX86 || test x$TARGET = xX86_WIN32 || test x$TARGET = xX86_64
fi
fi
+case "$target" in
+ *-apple-darwin10* | *-*-freebsd* | *-*-openbsd* | *-pc-solaris*)
+ AC_DEFINE(FFI_MMAP_EXEC_WRIT, 1,
+ [Cannot use malloc on this target, so, we revert to
+ alternative means])
+ ;;
+esac
+
AC_CACHE_CHECK([whether .eh_frame section should be read-only],
libffi_cv_ro_eh_frame, [
libffi_cv_ro_eh_frame=no