summaryrefslogtreecommitdiff
path: root/libffi/Makefile.am
diff options
context:
space:
mode:
authorandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2005-07-19 21:15:36 +0000
committerandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2005-07-19 21:15:36 +0000
commit569238e2e9c0a8dcd1f6dd3cab7f8eb8827b0bda (patch)
tree21351941ab537791da38bac3a026c412d513b438 /libffi/Makefile.am
parenta3986bc0093c3925be3dca4724e5e39b30149013 (diff)
downloadgcc-569238e2e9c0a8dcd1f6dd3cab7f8eb8827b0bda.tar.gz
2005-07-19 Andreas Tobler <a.tobler@schweiz.ch>
* Makefile.am (nodist_libffi_la_SOURCES): Add POWERPC_FREEBSD. * Makefile.in: Regenerate. * include/Makefile.in: Likewise. * testsuite/Makefile.in: Likewise. * configure.ac: Add POWERPC_FREEBSD rules. * configure: Regenerate. * src/powerpc/ffitarget.h: Add POWERPC_FREEBSD rules. (FFI_SYSV_TYPE_SMALL_STRUCT): Define. * src/powerpc/ffi.c: Add flags to handle small structure returns in ffi_call_SYSV. (ffi_prep_cif_machdep): Handle small structures for SYSV 4 ABI. Aka FFI_SYSV. (ffi_closure_helper_SYSV): Likewise. * src/powerpc/ppc_closure.S: Add return types for small structures. * src/powerpc/sysv.S: Add bits to handle small structures for final SYSV 4 ABI git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@102174 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/Makefile.am')
-rw-r--r--libffi/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/libffi/Makefile.am b/libffi/Makefile.am
index e11397e1215..89a2426b32d 100644
--- a/libffi/Makefile.am
+++ b/libffi/Makefile.am
@@ -117,6 +117,9 @@ endif
if POWERPC_DARWIN
nodist_libffi_la_SOURCES += src/powerpc/ffi_darwin.c src/powerpc/darwin.S src/powerpc/darwin_closure.S
endif
+if POWERPC_FREEBSD
+nodist_libffi_la_SOURCES += src/powerpc/ffi.c src/powerpc/sysv.S src/powerpc/ppc_closure.S
+endif
if ARM
nodist_libffi_la_SOURCES += src/arm/sysv.S src/arm/ffi.c
endif