summaryrefslogtreecommitdiff
path: root/libffi/Makefile.am
diff options
context:
space:
mode:
authorgreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-30 15:43:03 +0000
committergreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-30 15:43:03 +0000
commit2e818f508e564c53e9269ba6e3048c80f71be5a0 (patch)
treea36cbe1ac1d0a30e257ceffcce0d0b8b21e90faa /libffi/Makefile.am
parent092b1d6f29c36a1496c539d276bc9d0e1ce66082 (diff)
downloadgcc-2e818f508e564c53e9269ba6e3048c80f71be5a0.tar.gz
2004-08-30 Anthony Green <green@redhat.com>
* Makefile.am: Add frv support. * Makefile.in, testsuite/Makefile.in: Rebuilt. * configure.ac: Read configure.host. * configure, aclocal.m4: Rebuilt. * configure.host: New file. frv-elf needs libgloss. * include/ffi.h.in: Force ffi_closure to have a nice big (8) alignment. This is needed to frv and should harm the others. * include/ffi_common.h (ALIGN_DOWN): New macro. * src/frv/ffi.c, src/frv/ffitarget.h, src/frv/eabi.S: New files. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@86779 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/Makefile.am')
-rw-r--r--libffi/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/libffi/Makefile.am b/libffi/Makefile.am
index 9506c3f4319..6195d89859a 100644
--- a/libffi/Makefile.am
+++ b/libffi/Makefile.am
@@ -23,7 +23,7 @@ EXTRA_DIST = LICENSE ChangeLog.v1 \
src/sparc/ffi.c \
src/x86/ffi.c src/x86/sysv.S src/x86/win32.S \
src/x86/ffi64.c src/x86/unix64.S src/x86/ffitarget.h \
- src/pa/ffi.c src/pa/linux.S
+ src/pa/ffi.c src/pa/linux.S src/frv/eabi.S src/frv/ffitarget.h
## ################################################################
@@ -116,6 +116,9 @@ endif
if ARM
nodist_libffi_la_SOURCES += src/arm/sysv.S src/arm/ffi.c
endif
+if FRV
+nodist_libffi_la_SOURCES += src/frv/eabi.S src/frv/ffi.c
+endif
if S390
nodist_libffi_la_SOURCES += src/s390/sysv.S src/s390/ffi.c
endif