summaryrefslogtreecommitdiff
path: root/libf2c/configure.in
diff options
context:
space:
mode:
authorhp <hp@138bc75d-0d04-0410-961f-82ee72b054a4>2001-10-20 17:05:52 +0000
committerhp <hp@138bc75d-0d04-0410-961f-82ee72b054a4>2001-10-20 17:05:52 +0000
commit5c4a35ca9303ca312fb211396c6378361f2e8a7a (patch)
treebaa94dbcfadd465b92e726cc912bc1d855abe217 /libf2c/configure.in
parent8aa6160c68401099cc3e019dc3769199ebff00b2 (diff)
downloadgcc-5c4a35ca9303ca312fb211396c6378361f2e8a7a.tar.gz
* configure.in: Fake AC_EXEEXT invocation.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@46385 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libf2c/configure.in')
-rw-r--r--libf2c/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/libf2c/configure.in b/libf2c/configure.in
index 1746d0a21a1..ce3dcdc5092 100644
--- a/libf2c/configure.in
+++ b/libf2c/configure.in
@@ -69,6 +69,21 @@ dnl FIXME AC_PROG_CC wants CC to be able to link things, but it may
dnl not be able to.
define([AC_PROG_CC_WORKS],[])
+# We need AC_EXEEXT to keep automake happy in cygnus mode. However,
+# at least currently, we never actually build a program, so we never
+# need to use $(EXEEXT). Moreover, the test for EXEEXT normally
+# fails, because we are probably configuring with a cross compiler
+# which cant create executables. So we include AC_EXEEXT to keep
+# automake happy, but we dont execute it, since we dont care about
+# the result.
+if false; then
+ # autoconf 2.50 runs AC_EXEEXT by default, and the macro expands
+ # to nothing, so nothing would remain between `then' and `fi' if it
+ # were not for the `:' below.
+ :
+ AC_EXEEXT
+fi
+
# For g77 we'll set CC to point at the built gcc, but this will get it into
# the makefiles