summaryrefslogtreecommitdiff
path: root/libf2c/configure.in
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>1998-04-27 22:46:10 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>1998-04-27 22:46:10 +0000
commit5bb4fc9c93f3065747271972b1489dfcf3370389 (patch)
tree0fd39616303db543e7546f114e042dc7e4d283ed /libf2c/configure.in
parent560bc97b3e462bf701e06e57c899221321f85fa7 (diff)
downloadgcc-5bb4fc9c93f3065747271972b1489dfcf3370389.tar.gz
One more try at correct paths to f771 headers.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@19456 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libf2c/configure.in')
-rw-r--r--libf2c/configure.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/libf2c/configure.in b/libf2c/configure.in
index 3320f483b8d..69d05d7cdbd 100644
--- a/libf2c/configure.in
+++ b/libf2c/configure.in
@@ -253,12 +253,12 @@ fi
# is in ../.. and the config files are in $srcdir/../../config.
AC_MSG_CHECKING(f2c integer type)
late_ac_cpp=$ac_cpp
-if test "$srcdir" = . ; then
- ac_cpp="$late_ac_cpp -I../../gcc/f -I../../gcc -I../../gcc/config"
-else
- ac_cpp="$late_ac_cpp -I$srcdir/../gcc/f -I$srcdir/../gcc -I$srcdir/../gcc/config"
+ac_cpp="$late_ac_cpp -I../../gcc/f -I../../gcc -I../../gcc/config"
+if test "$subdir" != . ; then
+ ac_cpp="$ac_cpp -I$srcdir/../gcc/f -I$srcdir/../gcc -I$srcdir/../gcc/config"
fi
AC_CACHE_VAL(g77_cv_sys_f2cinteger,
+echo "configure:__oline__: using $ac_cpp" >&AC_FD_CC
AC_EGREP_CPP(F2C_INTEGER=long int,
[#include "proj.h"
#define FFECOM_DETERMINE_TYPES 1
@@ -273,6 +273,7 @@ F2C_INTEGER=int
],
g77_cv_sys_f2cinteger="long int",)
if test "$g77_cv_sys_f2cinteger" = ""; then
+echo "configure:__oline__: using $ac_cpp" >&AC_FD_CC
AC_EGREP_CPP(F2C_INTEGER=int,
[#include "proj.h"
#define FFECOM_DETERMINE_TYPES 1
@@ -299,12 +300,12 @@ AC_SUBST(F2C_INTEGER)
AC_MSG_CHECKING(f2c long int type)
late_ac_cpp=$ac_cpp
-if test "$srcdir" = . ; then
- ac_cpp="$late_ac_cpp -I../../gcc/f -I../../gcc -I../../gcc/config"
-else
- ac_cpp="$late_ac_cpp -I$srcdir/../gcc/f -I$srcdir/../gcc -I$srcdir/../gcc/config"
+ac_cpp="$late_ac_cpp -I../../gcc/f -I../../gcc -I../../gcc/config"
+if test "$subdir" != . ; then
+ ac_cpp="$ac_cpp -I$srcdir/../gcc/f -I$srcdir/../gcc -I$srcdir/../gcc/config"
fi
AC_CACHE_VAL(g77_cv_sys_f2clongint,
+echo "configure:__oline__: using $ac_cpp" >&AC_FD_CC
AC_EGREP_CPP(F2C_LONGINT=long int,
[#include "proj.h"
#define FFECOM_DETERMINE_TYPES 1
@@ -319,6 +320,7 @@ F2C_LONGINT=long long int
],
g77_cv_sys_f2clongint="long int",)
if test "$g77_cv_sys_f2clongint" = ""; then
+echo "configure:__oline__: using $ac_cpp" >&AC_FD_CC
AC_EGREP_CPP(F2C_LONGINT=long long int,
[#include "proj.h"
#define FFECOM_DETERMINE_TYPES 1