summaryrefslogtreecommitdiff
path: root/libdecnumber/configure.ac
diff options
context:
space:
mode:
authorDavid Edelsohn <dje.gcc@gmail.com>2020-05-23 21:41:45 +0000
committerDavid Edelsohn <dje.gcc@gmail.com>2020-05-23 21:59:02 +0000
commit731c4ce0e93065fb70db5faa2bd6c9c6bad56738 (patch)
tree30ee8c3aec27830439dd3cb670f4c8b7ef145f75 /libdecnumber/configure.ac
parenta57aa11191617754c8d43b3eb6a2576e970a0668 (diff)
downloadgcc-731c4ce0e93065fb70db5faa2bd6c9c6bad56738.tar.gz
libcpp, libdecnumber: configure and substitute AR
AIX supports "FAT" libraries containing 32 bit and 64 bit objects (similar to Darwin), but commands for manipulating libraries do not default to accept both 32 bit and 64 bit object files. While updating the AIX configuration to support building and running GCC as a 64 bit application, I have encountered some build libraries that hard code AR=ar instead of testing the environment. This patch adds AR_CHECK_TOOL(AR, ar) to configure.ac for the two libraries and updates Makefile.in to accept the substitution. 2020-05-23 David Edelsohn <dje.gcc@gmail.com> libcpp/ChangeLog: * Makefile.in (AR): Substitute @AR@. * configure.ac (CHECK_PROG AR): New. * configure: Regenerate. libdecnumber/ChangeLog: * Makefile.in (AR): Substitute @AR@. * configure.ac (CHECK_PROG AR): New. * configure: Regenerate.
Diffstat (limited to 'libdecnumber/configure.ac')
-rw-r--r--libdecnumber/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/libdecnumber/configure.ac b/libdecnumber/configure.ac
index de7e0088ceb..ae475a02c23 100644
--- a/libdecnumber/configure.ac
+++ b/libdecnumber/configure.ac
@@ -28,6 +28,7 @@ AC_CONFIG_AUX_DIR(..)
AC_PROG_MAKE_SET
AC_PROG_CC
AC_PROG_RANLIB
+AC_CHECK_TOOL(AR, ar)
MISSING=`cd $ac_aux_dir && ${PWDCMD-pwd}`/missing
AC_CHECK_PROGS([ACLOCAL], [aclocal], [$MISSING aclocal])