summaryrefslogtreecommitdiff
path: root/libcpp/configure.ac
diff options
context:
space:
mode:
authorsimonb <simonb@138bc75d-0d04-0410-961f-82ee72b054a4>2012-11-16 17:14:05 +0000
committersimonb <simonb@138bc75d-0d04-0410-961f-82ee72b054a4>2012-11-16 17:14:05 +0000
commit52bc861d91439efe60110d1b64280e401ddcf902 (patch)
tree709320b578253406cba90335431f68194bf6b70a /libcpp/configure.ac
parentb5228c55900494653f0f2050af2b7a5969461594 (diff)
downloadgcc-52bc861d91439efe60110d1b64280e401ddcf902.tar.gz
* include/cpplib.h (struct cpp_options): Add canonical_system_headers.
* files.c (find_file_in_dir): Call maybe_shorter_path() only if canonical_system_headers is set. * init.c (cpp_create_reader): Initialize canonical_system_headers. * configure.ac: Add new --enable-canonical-system-headers. * configure: Regenerate. * config.in: Regenerate. * doc/cppopts.texi: Document -f[no-]canonical-system-headers. * doc/install.texi: Document --enable-canonical-system-headers. * c.opt: Add f[no-]canonical-system-headers. * c-opts.c (c_common_handle_option): Handle OPT_fcanonical_system_headers. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@193569 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libcpp/configure.ac')
-rw-r--r--libcpp/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/libcpp/configure.ac b/libcpp/configure.ac
index e62da06ce27..34ae5c20622 100644
--- a/libcpp/configure.ac
+++ b/libcpp/configure.ac
@@ -132,6 +132,16 @@ if test $enable_checking != no ; then
[Define if you want more run-time sanity checks.])
fi
+AC_ARG_ENABLE(canonical-system-headers,
+[ --enable-canonical-system-headers
+ enable or disable system headers canonicalization],
+[],
+enable_canonical_system_headers=yes)
+if test $enable_canonical_system_headers != no; then
+ AC_DEFINE(ENABLE_CANONICAL_SYSTEM_HEADERS,
+ 1, [Define to enable system headers canonicalization.])
+fi
+
m4_changequote(,)
case $target in
aarch64*-*-* | \