summaryrefslogtreecommitdiff
path: root/libcpp/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2010-11-18 07:35:34 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2010-11-18 07:35:34 +0000
commitbe04fdf9c745375fa18e493ea025e77c60249086 (patch)
tree51a9f53a8b54f9f33e8b831f0f4b3041681ed540 /libcpp/configure.ac
parent07ee25f6d2982042a94634260157fc07c6fb0603 (diff)
downloadgcc-be04fdf9c745375fa18e493ea025e77c60249086.tar.gz
PR bootstrap/45538
* configure.ac: Use AC_USE_SYSTEM_EXTENSIONS. Remove switch of AC_LANG based on ENABLE_BUILD_WITH_CXX. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@166896 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libcpp/configure.ac')
-rw-r--r--libcpp/configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/libcpp/configure.ac b/libcpp/configure.ac
index 868986d8279..1c67eaf641c 100644
--- a/libcpp/configure.ac
+++ b/libcpp/configure.ac
@@ -14,6 +14,7 @@ AC_PROG_CC
AC_PROG_CXX
AC_PROG_RANLIB
+AC_USE_SYSTEM_EXTENSIONS
AC_SYS_LARGEFILE
# See if we are building gcc with C++.
@@ -58,18 +59,8 @@ fi
AC_HEADER_TIME
ACX_HEADER_STRING
-# AC_CHECK_HEADERS is repeated to work around apparent autoconf 2.59 bug. If
-# AC_CHECK_HEADERS comes after the if clause, the last AC_LANG call gets used,
-# no matter which branch is taken.
-if test "$ENABLE_BUILD_WITH_CXX" = "no"; then
- AC_LANG(C)
- AC_CHECK_HEADERS(locale.h fcntl.h limits.h stddef.h \
+AC_CHECK_HEADERS(locale.h fcntl.h limits.h stddef.h \
stdlib.h strings.h string.h sys/file.h unistd.h)
-else
- AC_LANG(C++)
- AC_CHECK_HEADERS(locale.h fcntl.h limits.h stddef.h \
- stdlib.h strings.h string.h sys/stat.h sys/file.h unistd.h)
-fi
# Checks for typedefs, structures, and compiler characteristics.
AC_C_BIGENDIAN