summaryrefslogtreecommitdiff
path: root/libcpp/configure.ac
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-25 08:10:02 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-25 08:10:02 +0000
commita668be2626dea959ddc34e2a8ddd8fb95327cf3e (patch)
tree99b4fbbaa5403868d9ec5c425af7303d39faab7c /libcpp/configure.ac
parent346e0763dcb885204cd96b050f67550cf5f79a06 (diff)
downloadgcc-a668be2626dea959ddc34e2a8ddd8fb95327cf3e.tar.gz
libcpp/ChangeLog:
2004-08-25 Paolo Bonzini <bonzini@gnu.org> * configure.ac: Replace Automake macro invocations with manual Autoconf checks and substitutions. * Makefile.am: Removed. * Makefile.in: Heavy simplification and reorganization. gcc/ChangeLog: 2004-08-25 Paolo Bonzini <bonzini@gnu.org> * doc/invoke.texi: Document that libcpp does not require Automake any longer. Document that Automake 1.9.1 should work everywhere. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@86541 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libcpp/configure.ac')
-rw-r--r--libcpp/configure.ac37
1 files changed, 33 insertions, 4 deletions
diff --git a/libcpp/configure.ac b/libcpp/configure.ac
index e9d57dc762b..5b59bdcbc8f 100644
--- a/libcpp/configure.ac
+++ b/libcpp/configure.ac
@@ -5,13 +5,18 @@ AC_PREREQ(2.59)
AC_INIT(cpplib, [ ], gcc-bugs@gcc.gnu.org, cpplib)
AC_CONFIG_SRCDIR(ucnid.h)
AC_CANONICAL_SYSTEM
-AM_INIT_AUTOMAKE(foreign)
-AM_MAINTAINER_MODE
+AC_PROG_MAKE_SET
+AC_PROG_INSTALL
# Checks for programs.
AC_PROG_CC
AC_PROG_RANLIB
+MISSING=`cd $ac_aux_dir && ${PWDCMD-pwd}`/missing
+AC_CHECK_PROGS([ACLOCAL], [aclocal], [$MISSING aclocal])
+AC_CHECK_PROGS([AUTOCONF], [autoconf], [$MISSING autoconf])
+AC_CHECK_PROGS([AUTOHEADER], [autoheader], [$MISSING autoheader])
+
# Checks for header files.
AC_HEADER_TIME
ACX_HEADER_STRING
@@ -52,7 +57,29 @@ if test $ac_cv_type_uchar = yes; then
fi
AM_ICONV
-AM_CONDITIONAL(ENABLE_NLS, [test "x$enable_nls" != xno])
+
+# More defines and substitutions.
+AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [Define to the name of this package.])
+AC_SUBST(PACKAGE)
+
+if test "x$enable_nls" != xno; then
+ USED_CATALOGS='$(CATALOGS)'
+else
+ USED_CATALOGS=
+fi
+AC_SUBST(USED_CATALOGS)
+
+AC_ARG_ENABLE(maintainer-mode,
+[ --enable-maintainer-mode enable rules only needed by maintainers],,
+enable_maintainer_mode=no)
+
+if test "x$enable_maintainer_mode" = xno; then
+ MAINT='#'
+else
+ MAINT=
+fi
+AC_SUBST(MAINT)
+
AC_ARG_ENABLE(checking,
[ --enable-checking enable expensive run-time checks],,
enable_checking=no)
@@ -94,6 +121,8 @@ AC_DEFINE_UNQUOTED(HOST_WIDE_INT, $host_wide_int,
[Define to the widest efficient host integer type at least
as wide as the target's size_t type.])
-AC_CONFIG_HEADERS(config.h:config.in)
+# Output.
+
+AC_CONFIG_HEADERS(config.h:config.in, [echo timestamp > stamp-h1])
AC_CONFIG_FILES(Makefile)
AC_OUTPUT