summaryrefslogtreecommitdiff
path: root/libatomic/configure.ac
diff options
context:
space:
mode:
authorSteve Ellcey <sellcey@cavium.com>2017-12-05 00:49:09 +0000
committerSteve Ellcey <sje@gcc.gnu.org>2017-12-05 00:49:09 +0000
commit141abc6f1e5a6a2de0a1ee97b63d56ee50b85a66 (patch)
tree50d25ec32b7f404446f4f5da5e0991c3ae3339f1 /libatomic/configure.ac
parentad8503503f69f99b17e22cf53d87fe6e15256912 (diff)
downloadgcc-141abc6f1e5a6a2de0a1ee97b63d56ee50b85a66.tar.gz
Makefile.am (ARCH_AARCH64_LINUX): Add IFUNC_OPTIONS and libatomic_la_LIBADD.
2017-12-04 Steve Ellcey <sellcey@cavium.com> * Makefile.am (ARCH_AARCH64_LINUX): Add IFUNC_OPTIONS and libatomic_la_LIBADD. * config/linux/aarch64/host-config.h: New file. * configure.ac (IFUNC_RESOLVER_ARGS): Define. (ARCH_AARCH64_LINUX): New conditional for IFUNC builds. * configure.tgt (aarch64): Set ARCH and try_ifunc. (aarch64*-*-linux*) Update config_path. (aarch64*-*-linux*) Set IFUNC_RESOLVER_ARGS. * libatomic_i.h (GEN_SELECTOR): Add IFUNC_RESOLVER_ARGS argument. * Makefile.in: Regenerate. * auto-config.h.in: Regenerate. * configure: Regenerate. From-SVN: r255399
Diffstat (limited to 'libatomic/configure.ac')
-rw-r--r--libatomic/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libatomic/configure.ac b/libatomic/configure.ac
index bf7315e78d1..6b11f21a03e 100644
--- a/libatomic/configure.ac
+++ b/libatomic/configure.ac
@@ -163,6 +163,10 @@ if test -n "$UNSUPPORTED"; then
AC_MSG_ERROR([Configuration ${target} is unsupported.])
fi
+# Write out the ifunc resolver arg type.
+AC_DEFINE_UNQUOTED(IFUNC_RESOLVER_ARGS, $IFUNC_RESOLVER_ARGS,
+ [Define ifunc resolver function argument.])
+
# Disable fallbacks to __sync routines from libgcc. Otherwise we'll
# make silly decisions about what the cpu can do.
CFLAGS="$save_CFLAGS -fno-sync-libcalls $XCFLAGS"
@@ -251,6 +255,8 @@ AC_SUBST(LIBS)
AC_SUBST(SIZES)
AM_CONDITIONAL(HAVE_IFUNC, test x$libat_cv_have_ifunc = xyes)
+AM_CONDITIONAL(ARCH_AARCH64_LINUX,
+ [expr "$config_path" : ".* linux/aarch64 .*" > /dev/null])
AM_CONDITIONAL(ARCH_ARM_LINUX,
[expr "$config_path" : ".* linux/arm .*" > /dev/null])
AM_CONDITIONAL(ARCH_I386,