summaryrefslogtreecommitdiff
path: root/libatomic/Makefile.am
diff options
context:
space:
mode:
authornsz <nsz@138bc75d-0d04-0410-961f-82ee72b054a4>2016-01-06 14:51:35 +0000
committernsz <nsz@138bc75d-0d04-0410-961f-82ee72b054a4>2016-01-06 14:51:35 +0000
commit371db734bc7f4b5faee36029b971ba1cb44a9607 (patch)
tree444dfe130e7c482dd2feae37033602b82702fc82 /libatomic/Makefile.am
parent935f7e97a38d5c0607845dcda85817e4f73223b4 (diff)
downloadgcc-371db734bc7f4b5faee36029b971ba1cb44a9607.tar.gz
Fix libatomic multilib parallel build (PR other/67627)
The all-multi target may be built in parallel with the %_.lo targets which generate make dependencies that are parsed during the build of all-multi. This patch forces all-multi to only run after the *_.lo targets are done. libatomic: PR other/67627 * Makefile.am (all-multi): Add dependency. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@232102 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libatomic/Makefile.am')
-rw-r--r--libatomic/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/libatomic/Makefile.am b/libatomic/Makefile.am
index fdc16c0ac91..b3512442850 100644
--- a/libatomic/Makefile.am
+++ b/libatomic/Makefile.am
@@ -139,3 +139,10 @@ endif
libatomic_convenience_la_SOURCES = $(libatomic_la_SOURCES)
libatomic_convenience_la_LIBADD = $(libatomic_la_LIBADD)
+
+# Override the automake generated all-multi rule to guarantee that all-multi
+# is not run in parallel with the %_.lo rules which generate $(DEPDIR)/*.Ppo
+# makefile fragments to avoid broken *.Ppo getting included into the Makefile
+# when it is reloaded during the build of all-multi.
+all-multi: $(libatomic_la_LIBADD)
+ $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do # $(MAKE)