summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorZack Weinberg <zack@gcc.gnu.org>2001-11-30 04:43:05 +0000
committerZack Weinberg <zack@gcc.gnu.org>2001-11-30 04:43:05 +0000
commit06f0b04cab15bdd864387366f84ad86a472e406b (patch)
tree2bb735450d7699f18d71d9f8c5a346f36f7cbfc9 /gcc/configure.in
parent998979e6dc20eb1b72f6f9a1a818ae28d07d8721 (diff)
downloadgcc-06f0b04cab15bdd864387366f84ad86a472e406b.tar.gz
Purge cruft now we have build libiberty.
* Makefile.in (OBSTACK, VFPRINTF, DOPRINT, STRSTR, HOST_OBSTACK, HOST_VFPRINTF, HOST_DOPRINT, HOST_STRSTR, USE_HOST_OBSTACK, USE_HOST_VFPRINTF, USE_HOST_DOPRINT, USE_HOST_STRSTR): Delete variables. (vfprintf.o, doprint.o, strstr.o, splay-tree.o, obstack.o, hashtab.o, safe-ctype.o, $(HOST_PREFIX_1)obstack.o, $(HOST_PREFIX_1)vfprintf.o, $(HOST_PREFIX_1)doprint.o, $(HOST_PREFIX_1)strstr.o), $(HOST_PREFIX_1)): Delete rules. (LIBIBERTY, BUILD_LIBIBERTY): New variables. (LIBDEPS): Now just $(INTLDEPS) $(LIBIBERTY). (LIBS): Now just $(INTLLIBS) @LIBS@ $(LIBIBERTY). (HOST_LIBDEPS): Now just $(BUILD_LIBIBERTY). (HOST_LIBS): Ditto. (HOST_RTL): Remove hashtab.o safe-ctype.o. (OBJS): Remove splay-tree.o. (gen-protos): Depend on $(HOST_LIBS), not ../libiberty/libiberty.a. (distclean): No need to delete splay-tree.c obstack.c hashtab.c safe-ctype.c. (mostlyclean): Delete build copies of print-rtl.c bitmap.c errors.c ggc-none.c (all prefixed with $(HOST_PREFIX_1). * aclocal.m4 (gcc_AC_FUNC_VFPRINTF_DOPRNT, gcc_AC_FUNC_STRSTR): Delete. * configure.in: Don't use them. Set and substitute @FORBUILD@. * config.in, configure: Regenerate. * doprint.c: Move to libiberty/_doprnt.c. * doc/configterms.texi: Document that libiberty is now built up to three times. Fix typo. * f/Make-lang.in (f/fini, f/intdoc): Depend on $(HOST_LIBDEPS) and link with $(HOST_LIBS), not safe-ctype.o. From-SVN: r47475
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index eebf810c09b..459de336a32 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -606,8 +606,6 @@ else
fi
AC_SUBST(TARGET_GETGROUPS_T)
-gcc_AC_FUNC_VFPRINTF_DOPRNT
-gcc_AC_FUNC_STRSTR
gcc_AC_FUNC_PRINTF_PTR
case "${host}" in
@@ -838,6 +836,7 @@ fi
if test x$host = x$build
then
build_auto=auto-host.h
+ FORBUILD=..
else
# We create a subdir, then run autoconf in the subdir.
# To prevent recursion we set host and build for the new
@@ -863,7 +862,9 @@ else
cd ..
rm -rf $tempdir
build_auto=auto-build.h
+ FORBUILD=../$build
fi
+AC_SUBST(FORBUILD)
tm_file="${tm_file} defaults.h"
host_xm_file="auto-host.h ansidecl.h ${host_xm_file} ${tm_file}"