summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2003-03-28 23:15:42 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2003-03-28 23:15:42 +0000
commitd2aaa43fc519b82123968b9f5046d6e55047fe97 (patch)
treec7247e7e95c5000b14b5427a52634801784eac63 /gcc/configure.in
parent6277efbe76e89d6009cbff94e8060097165aa94c (diff)
downloadgcc-d2aaa43fc519b82123968b9f5046d6e55047fe97.tar.gz
2003-03-28 Nathanael Nerode <neroden@gcc.gnu.org>
* configure.in: Clarify comments. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@64990 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index dd922c1a78f..b48bd22bf77 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -1448,7 +1448,13 @@ if test -f ../ld/Makefile; then
rm -f collect-ld; $symbolic_link ../ld/ld-new$host_exeext collect-ld$host_exeext 2>/dev/null
fi
-# Figure out what assembler we will be using.
+# Identify the assembler which will work hand-in-glove with the newly
+# built GCC, so that we can examine its features. This is the assembler
+# which will be driven by the driver program.
+#
+# If build != host, and we aren't building gas in-tree, we identify a
+# build->target assembler and hope that it will have the same features
+# as the host->target assembler we'll be using.
AC_MSG_CHECKING(what assembler to use)
in_tree_gas=no
gcc_cv_as=
@@ -1537,7 +1543,13 @@ case $in_tree_gas in
;;
esac
-# Figure out what linker we will be using.
+# Identify the linker which will work hand-in-glove with the newly
+# built GCC, so that we can examine its features. This is the linker
+# which will be driven by the driver program.
+#
+# If build != host, and we aren't building gas in-tree, we identify a
+# build->target linker and hope that it will have the same features
+# as the host->target linker we'll be using.
AC_MSG_CHECKING(what linker to use)
in_tree_ld=no
gcc_cv_ld=