summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authordrow <drow@138bc75d-0d04-0410-961f-82ee72b054a4>2003-06-04 17:50:44 +0000
committerdrow <drow@138bc75d-0d04-0410-961f-82ee72b054a4>2003-06-04 17:50:44 +0000
commit7dd97ab62695cb000e76a6f7097a5ba9027aff9c (patch)
tree0761aad7dc475440590406dcf0a0052331286e05 /gcc/configure.in
parentf0b281fea1edd49e9684a26761d476f7625aa0a7 (diff)
downloadgcc-7dd97ab62695cb000e76a6f7097a5ba9027aff9c.tar.gz
* config.gcc: Reorganize --with-cpu logic. Set
configure_default_options according to the default CPU, --with-cpu, --with-arch, --with-tune, --with-schedule, --with-abi, and --with-float. Check for legal values of various options. * configure.in: Define configure_default_options in configargs.h. * configure: Regenerated. * config/mips/mips.h (TARGET_DEFAULT_ARCH_P) (TARGET_DEFAULT_FLOAT_P): New macros. * gcc.c (do_option_spec): New function. (struct default_spec, option_default_specs): New. (main): Call do_option_spec. * config/alpha/alpha.h, config/arm/arm.h, config/i386/i386.h, config/mips/mips.h, config/pa/pa.h, config/rs6000/rs6000.h, config/sparc/sparc.h (OPTION_DEFAULT_SPECS): Define. * doc/install.texi: Update --with-cpu documentation. Mention --with-arch, --with-schedule, --with-tune, --with-abi, and --with-float. * doc/tm.texi (Driver): Document OPTION_DEFAULT_SPECS. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@67457 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index b9e48324c60..501bdb7d2e0 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -1215,6 +1215,10 @@ cat > configargs.h <<EOF
/* Generated automatically. */
static const char configuration_arguments[] = "$gcc_config_arguments";
static const char thread_model[] = "$thread_file";
+
+static const struct {
+ const char *name, *value;
+} configure_default_options[] = $configure_default_options;
EOF
changequote([,])dnl