summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2003-09-04 21:38:59 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2003-09-04 21:38:59 +0000
commit65cce9df498b107a3a7cc06a562db002b4dbdc92 (patch)
tree67d77ab418e0de23d7e39d69532d5a32fc26419c /gcc/configure.in
parent9ad4bb1ec3eb37d0a10bf2de7981b7cfec09cbb9 (diff)
downloadgcc-65cce9df498b107a3a7cc06a562db002b4dbdc92.tar.gz
* configure.in (gcc_cv_as_ix86_cmov_sun_syntax): Check if
assembler supports Sun syntax for cmov. * configure: Regenerate. * config.in: Likewise. * config/i386/i386.c: Rename CMOV_SUN_AS_SYNTAX to HAVE_AS_IX86_CMOV_SUN_SYNTAX. * config/i386/sol2.h (CMOV_SUN_AS_SYNTAX): Remove. Fixes PR target/12101. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@71089 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index ff4d26889a9..c6c6bae2fef 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -2263,6 +2263,12 @@ changequote([,])dnl
[AC_DEFINE(HAVE_GAS_FILDS_FISTS, 1,
[Define if your assembler uses the new HImode fild and fist notation.])])
+ gcc_GAS_CHECK_FEATURE([cmov syntax],
+ gcc_cv_as_ix86_cmov_sun_syntax,,,
+ [cmovl.l %edx, %eax],,
+ [AC_DEFINE(HAVE_AS_IX86_CMOV_SUN_SYNTAX, 1,
+ [Define if your assembler supports the Sun syntax for cmov.])])
+
# This one is used unconditionally by i386.[ch]; it is to be defined
# to 1 if the feature is present, 0 otherwise.
gcc_GAS_CHECK_FEATURE([GOTOFF in data],