summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-08 23:20:18 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-08 23:20:18 +0000
commit95126477945260e657fdda3244201b4d0b0d70ef (patch)
treed14e895aa0f643740cf9f9a9fc9ac99f2e746d48 /gcc/configure.in
parente3fff6f226714d15ecd144e99828cbdd25bc2bb5 (diff)
downloadgcc-95126477945260e657fdda3244201b4d0b0d70ef.tar.gz
* Makefile.in (libgcc.mk): Pass SHLIB_EXT, not SHLIB_LIBS.
* configure.in (sparc*-*-solaris*): Use t-slibgcc{,-sld}. * mklibgcc.in: Consider SHLIB_LINK the entire shlib build command. Use SHLIB_EXT. * config/t-linux (SHLIB_EXT): New. (SHLIB_LINK): Use the entire build command, with substitutions. (SHLIB_LIBS): Remove. * config/alpha/t-osf4: Likewise. * config/mips/t-iris6: Likewise. * config/sparc/t-sol2: Likewise, but move shlib stuff... * config/sparc/t-slibgcc-sld: ...here. * config/sparc/t-slibgcc: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@36792 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 9090db896d6..ff55d73e53e 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -3486,6 +3486,11 @@ changequote([,])dnl
xm_file="sparc/xm-sysv4-64.h sparc/xm-sol2.h"
xm_defines="USG POSIX"
tmake_file="sparc/t-sol2 sparc/t-sol2-64"
+ if test x$gnu_ld = xyes; then
+ tmake_file="$tmake_file sparc/t-slibgcc"
+ else
+ tmake_file="$tmake_file sparc/t-slibgcc-sld"
+ fi
xmake_file=sparc/x-sysv4
extra_parts="crt1.o crti.o crtn.o gcrt1.o crtbegin.o crtend.o"
float_format=none
@@ -3508,6 +3513,11 @@ changequote([,])dnl
xm_defines="USG POSIX"
tm_file="sparc/sol2.h sparc/hal.h"
tmake_file="sparc/t-halos sparc/t-sol2"
+ if test x$gnu_ld = xyes; then
+ tmake_file="$tmake_file sparc/t-slibgcc"
+ else
+ tmake_file="$tmake_file sparc/t-slibgcc-sld"
+ fi
xmake_file=sparc/x-sysv4
extra_parts="crt1.o crti.o crtn.o gmon.o crtbegin.o crtend.o"
case $machine in
@@ -3532,6 +3542,11 @@ changequote([,])dnl
xm_file="sparc/xm-sysv4.h sparc/xm-sol2.h"
xm_defines="USG POSIX"
tmake_file=sparc/t-sol2
+ if test x$gnu_ld = xyes; then
+ tmake_file="$tmake_file sparc/t-slibgcc"
+ else
+ tmake_file="$tmake_file sparc/t-slibgcc-sld"
+ fi
xmake_file=sparc/x-sysv4
extra_parts="crt1.o crti.o crtn.o gcrt1.o gmon.o crtbegin.o crtend.o"
# At the moment, 32-to-64 cross compilation doesn't work.