summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorneil <neil@138bc75d-0d04-0410-961f-82ee72b054a4>2000-11-02 19:41:19 +0000
committerneil <neil@138bc75d-0d04-0410-961f-82ee72b054a4>2000-11-02 19:41:19 +0000
commit83ae3cdf31714f761d29da9f4f9fd2fbff1c8d4e (patch)
tree426b435a2e38e45a07278cf9586fa972b7f0f1a1 /gcc/configure.in
parent066034a153e1f0efa35f9ac292e45ee2617915a4 (diff)
downloadgcc-83ae3cdf31714f761d29da9f4f9fd2fbff1c8d4e.tar.gz
* configure.in: Make integrated CPP the default.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@37208 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 9f7b7b040d0..02a97ef4b76 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -254,16 +254,19 @@ elif test x$withval != xno; then
cpp_install_dir=$withval
fi])
-# Link cpplib into the compiler proper, for C/C++/ObjC.
-maybe_cpplib=
+# Link cpplib into the compiler proper, for C/C++/ObjC. Defaults to on.
+maybe_cpplib=libcpp.a
AC_ARG_ENABLE(c-cpplib,
[ --enable-c-cpplib link cpplib directly into C and C++ compilers
(HIGHLY EXPERIMENTAL).],
-if test x$enable_c_cpplib != xno; then
- maybe_cpplib=libcpp.a
+[if test x$enable_c_cpplib != xyes; then
+ maybe_cpplib=
+fi]
+)
+if test x$maybe_cpplib != x ; then
AC_DEFINE(USE_CPPLIB, 1,
[Define if you want the preprocessor merged into the C and C++ compilers.])
-fi)
+fi
AC_SUBST(maybe_cpplib)
# Enable Multibyte Characters for C/C++