summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authordavem <davem@138bc75d-0d04-0410-961f-82ee72b054a4>1998-09-24 02:44:55 +0000
committerdavem <davem@138bc75d-0d04-0410-961f-82ee72b054a4>1998-09-24 02:44:55 +0000
commit447b4bf2e34e623ededbbf55a715da4ade652dd3 (patch)
treeccabaa4bdfb06ec166cddcefdd27f29fe835a5b0 /gcc/configure.in
parent7be2ca7d542f2728332702b28c4daf59f050193a (diff)
downloadgcc-447b4bf2e34e623ededbbf55a715da4ade652dd3.tar.gz
Thu Sep 24 01:35:34 1998 David S. Miller <davem@pierdol.cobaltmicro.com>
* config/sparc/sol2-sld-64.h (TRANSFER_FROM_TRAMPOLINE): Define. * config/sparc/sparc.c (sparc64_initialize_trampoline): If that is defined, emit libcall to __enable_execute_stack. Also fix opcodes and offsets in actual stack trampoline code so they match the commentary and actually work. Thu Sep 24 01:19:02 1998 Jakub Jelinek <jj@sunsite.ms.mff.cuni.cz> * configure.in (sparcv9-*-solaris): Use t-sol2 and t-sol2-64 for tmake_file. (sparc64-*-linux): Use t-linux and sparc/t-linux64 for tmake_file. Set extra_parts to needed crt objects. * configure: Rebuilt. * config/sparc/linux64.h (SPARC_BI_ARCH): Define. (TARGET_DEFAULT): Set if default is v9 or ultra. (STARTFILE_SPEC32, STARTFILE_SPEC64): New macros. (STARTFILE_SPEC): Set to those upon SPARC_BI_ARCH. (ENDFILE_SPEC32, ENDFILE_SPEC64, ENDFILE_SPEC): Likewise. (SUBTARGET_EXTRA_SPECS, LINK_ARCH32_SPEC, LINK_ARCH64_SPEC, LINK_SPEC, LINK_ARCH_SPEC): Likewise. (TARGET_VERSION): Define. (MULTILIB_DEFAULT): Define. * config/sparc/sparc.h (CPP_CPU_DEFAULT_SPEC): Rearrange so that mixed 32/64 bit compilers based upon SPARC_BI_ARCH work. (CPP_CPU64_DEFAULT_SPEC, CPP_CPU32_DEFAULT_SEC): Define appropriately. (TARGET_SWITCHES): Allow ptr32/ptr64 options once more. * config/sparc/sparc.c (sparc_override_options): If arch and pointer size disagree, emit diagnostic and fix it up. If SPARC_BI_ARCH and TARGET_ARCH32, set cmodel to CM_32. Turn off V8PLUS in 64-bit mode. * config/sparc/t-linux64: New file. * config/sparc/t-sol2-64: New file. * config/sparc/t-sol2: Adjust build rules to use MULTILIB_CFLAGS. * config/sparc/sol2-sld-64.h (SPARC_BI_ARCH): Define. (ASM_CPU32_DEFAULT_SPEC, ASM_CPU64_DEFAULT_SPEC, CPP_CPU32_DEFAULT_SPEC, CPP_CPU64_DEFAULT_SPEC): Define. (ASM_SPEC, CPP_CPU_SPEC): Set appropriately based upon those. (STARTFILE_SPEC32, STARTFILE_SPEC32, STARTFILE_ARCH_SPEC): Define. (STARTFILE_SPEC): Set approriately based upon those. (CPP_CPU_DEFAULT_SPEC, ASM_CPU_DEFAULT_SPEC): Set based upon disposition of DEFAULT_ARCH32_P. (LINK_ARCH32_SPEC, LINK_ARCH64_SPEC): Define. (LINK_ARCH_SPEC, LINK_ARCH_DEFAULT_SPEC): Set based upon those. (CC1_SPEC, MULTILIB_DEFAULTS): Set based upon DEFAULT_ARCH32_P. (MD_STARTFILE_PREFIX): Set correctly based upon SPARC_BI_ARCH. * config/sparc/xm-sysv4-64.h (HOST_BITS_PER_LONG): Only set on arch64/v9. * config/sparc/xm-sp64.h (HOST_BITS_PER_LONG): Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@22565 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 1833279feb3..5e1b434fa4d 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -2878,7 +2878,7 @@ changequote([,])dnl
tm_file=sparc/sol2-sld-64.h
xm_file="sparc/xm-sysv4-64.h sparc/xm-sol2.h"
xm_defines="USG POSIX"
- tmake_file=sparc/t-sol2
+ tmake_file="sparc/t-sol2 sparc/t-sol2-64"
xmake_file=sparc/x-sysv4
extra_parts="crt1.o crti.o crtn.o gcrt1.o crtbegin.o crtend.o"
fixincludes=fixinc.wrap
@@ -2986,11 +2986,12 @@ changequote([,])dnl
extra_parts="crtbegin.o crtend.o"
;;
sparc64-*-linux*) # 64-bit Sparc's running GNU/Linux
- tmake_file=sparc/t-sp64
+ tmake_file="t-linux sparc/t-linux64"
xm_file="sparc/xm-sp64.h sparc/xm-linux.h"
tm_file=sparc/linux64.h
xmake_file=x-linux
fixincludes=Makefile.in # The headers are ok already.
+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
gnu_ld=yes
;;
# This hasn't been upgraded to GCC 2.