summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorBrendan Kehoe <brendan@lisa.cygnus.com>1997-09-18 19:50:51 +0000
committerBrendan Kehoe <brendan@gcc.gnu.org>1997-09-18 15:50:51 -0400
commit93cf819deee955ccd7432bbc2b0d642523ed155b (patch)
treec364db7161f3f35aefcc147e98447ba22aff1f55 /gcc/configure.in
parentf05011492be2d32526bbc5303d1121dd70ed9a1c (diff)
downloadgcc-93cf819deee955ccd7432bbc2b0d642523ed155b.tar.gz
configure.in, configure: Make sure to create the stage* and include symbolic links in each subdirectory.
* configure.in, configure: Make sure to create the stage* and include symbolic links in each subdirectory. copy that's also now in at the FSF; only does it if $symbolic_link is defined to `ln -s' From-SVN: r15543
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in17
1 files changed, 12 insertions, 5 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 4d991f93df6..f0b6a49053e 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -3147,9 +3147,15 @@ case x$CONFIG_HEADERS in
xconfig.h:config.in)
echo > cstamp-h ;;
esac
-# Make sure we create things so -Bstage1/ will work.
-for d in .. ${subdirs} ; do
- if [ $d != .. ]; then
+# If the host supports symlinks, point stage[1234] at ../stage[1234] so
+# bootstrapping and the installation procedure can still use
+# CC="stage1/xgcc -Bstage1/". If the host doesn't support symlinks,
+# FLAGS_TO_PASS has been modified to solve the problem there.
+# This is virtually a duplicate of what happens in configure.lang; we do
+# an extra check to make sure this only happens if ln -s can be used.
+if [[ "$symbolic_link" = "ln -s" ]]; then
+ for d in .. ${subdirs} ; do
+ if [[ $d != .. ]]; then
STARTDIR=`pwd`
cd $d
for t in stage1 stage2 stage3 stage4 include
@@ -3158,8 +3164,9 @@ for d in .. ${subdirs} ; do
$symbolic_link ../$t $t 2>/dev/null
done
cd $STARTDIR
- fi
-done
+ fi
+ done
+else true ; fi
],
[
host='${host}'