summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorZack Weinberg <zack@gcc.gnu.org>2001-03-03 03:32:55 +0000
committerZack Weinberg <zack@gcc.gnu.org>2001-03-03 03:32:55 +0000
commiteaf4e6183e957581cc1a01378a88f7ca571e7db7 (patch)
treef194838a82706bc950961ea554c14f5271f5e0ac /gcc/configure.in
parent1a7519ff614294ba8b234a1e605066cac3029220 (diff)
downloadgcc-eaf4e6183e957581cc1a01378a88f7ca571e7db7.tar.gz
configure.in: Kill tm.h.
* configure.in: Kill tm.h. Include the files in the $tm_file list in all three of config.h, hconfig.h, tconfig.h, after the relevant set of xm_files. Put TARGET_CPU_DEFAULT in all three, include insn-codes.h in all three (#ifndef GENERATOR_FILE). * configure: Regenerate. * Makefile.in (clean): Don't delete tm.h. * system.h: If SUCCESS_EXIT_CODE and FATAL_EXIT_CODE are not defined, set them from EXIT_SUCCESS and EXIT_FAILURE. If those are not defined, set SEC and FEC to 0 and 1. * gcc.texi: Update to match. * crtstuff.c: Include tconfig.h, not auto-host.h and tm.h. * config/fp-bit.c, config/m68k/aux-crt2.asm, config/m68k/aux-crtn.asm, config/m68k/aux-mcount.c: Include tconfig.h, not tm.h. * config/xm-lynx.h, config/xm-std32.h, config/a29k/xm-a29k.h, config/a29k/xm-unix.h, config/alpha/xm-alpha.h, config/arc/xm-arc.h, config/avr/xm-avr.h, config/c4x/xm-c4x.h, config/clipper/xm-clix.h, config/convex/xm-convex.h, config/d30v/xm-d30v.h, config/dsp16xx/xm-dsp16xx.h, config/elxsi/xm-elxsi.h, config/fr30/xm-fr30.h, config/h8300/xm-h8300.h, config/i370/xm-linux.h, config/i386/xm-i386.h, config/i860/xm-i860.h, config/i960/xm-i960.h, config/ia64/xm-ia64.h, config/m32r/xm-m32r.h, config/m68hc11/xm-m68hc11.h, config/m88k/xm-m88k.h, config/mcore/xm-mcore.h, config/mips/xm-mips.h, config/mn10200/xm-mn10200.h, config/mn10300/xm-mn10300.h, config/ns32k/xm-ns32k.h, config/pa/xm-linux.h, config/pa/xm-pa.h, config/pa/xm-pa64hpux.h, config/pa/xm-pahpux.h, config/pa/xm-papro.h, config/pdp11/xm-pdp11.h, config/pj/xm-pj.h, config/romp/xm-romp.h, config/rs6000/xm-beos.h, config/rs6000/xm-rs6000.h, config/rs6000/xm-sysv4.h, config/sh/xm-sh.h, config/sparc/xm-sparc.h, config/sparc/xm-sysv4.h, config/v850/xm-v850.h, config/vax/xm-vax.h, config/we32k/xm-we32k.h: Don't include tm.h. Don't define SUCCESS_EXIT_CODE or FATAL_EXIT_CODE. * config/i370/xm-i370.h, config/i370/xm-mvs.h, config/i370/xm-oe.h: Don't include tm.h. Don't define SUCCESS_EXIT_CODE. * config/vax/xm-vms.h: Don't include tm.h. * config/xm-lynx.h, config/avr/xm-avr.h, config/fr30/xm-fr30.h, config/pdp11/xm-pdp11.h, Delete; made empty by above changes. * config/i386/xm-lynx.h, config/m68k/xm-lynx.h, config/rs6000/xm-lynx.h, config/sparc/xm-lynx.h: Don't include config/xm-lynx.h or tm.h. * config/xm-gnu.h: Don't include fcntl.h. * config/sparc/xm-lynx.h: Don't include sys/types.h and sys/wait.h. * config/clipper/xm-clix.h, config/vax/xm-vax.h: Don't define isinf. From-SVN: r40199
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in36
1 files changed, 17 insertions, 19 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 3a9b5dee388..23973687d85 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -716,15 +716,13 @@ fi
# $vars is the list of shell variables with file names to include.
# auto-host.h is the file containing items generated by autoconf and is
# the first file included by config.h.
-null_defines=
-host_xm_file="auto-host.h gansidecl.h ${host_xm_file} defaults.h hwint.h"
-
# If host=build, it is correct to have hconfig include auto-host.h
# as well. If host!=build, we are in error and need to do more
# work to find out the build config parameters.
+# FIXME: hconfig.h should be bconfig.h.
if test x$host = x$build
then
- build_xm_file="auto-host.h gansidecl.h ${build_xm_file} defaults.h hwint.h"
+ build_auto=auto-host.h
else
# We create a subdir, then run autoconf in the subdir.
# To prevent recursion we set host and build for the new
@@ -746,15 +744,18 @@ else
mv auto-host.h ../auto-build.h
cd ..
rm -rf $tempdir
- build_xm_file="auto-build.h gansidecl.h ${build_xm_file} defaults.h hwint.h"
+ build_auto=auto-build.h
fi
-xm_file="gansidecl.h ${xm_file} defaults.h"
-tm_file="gansidecl.h ${tm_file} defaults.h"
+null_defines=
+tm_file="${tm_file} defaults.h"
+host_xm_file="auto-host.h gansidecl.h ${host_xm_file} ${tm_file} hwint.h"
+build_xm_file="${build_auto} gansidecl.h ${build_xm_file} ${tm_file} hwint.h"
+xm_file="gansidecl.h ${xm_file} ${tm_file}"
-vars="host_xm_file tm_file tm_p_file xm_file build_xm_file"
-links="config.h tm.h tm_p.h tconfig.h hconfig.h"
-defines="host_xm_defines null_defines null_defines xm_defines build_xm_defines"
+vars="host_xm_file tm_p_file xm_file build_xm_file"
+links="config.h tm_p.h tconfig.h hconfig.h"
+defines="host_xm_defines null_defines xm_defines build_xm_defines"
rm -f config.bak
if test -f config.status; then mv -f config.status config.bak; fi
@@ -772,7 +773,7 @@ do
# Define TARGET_CPU_DEFAULT if the system wants one.
# This substitutes for lots of *.h files.
- if test "$target_cpu_default" != "" -a $link = tm.h
+ if test "$target_cpu_default" != ""
then
echo "#define TARGET_CPU_DEFAULT ($target_cpu_default)" >>$link
fi
@@ -801,14 +802,11 @@ do
echo "#endif" >>$link
done
- if test $link = tm.h
- then
- # Include insn-codes.h last, because it includes machmode.h,
- # and we want EXTRA_CC_MODES to be taken into account.
- echo "#ifndef GENERATOR_FILE" >>$link
- echo "#include \"insn-codes.h\"" >>$link
- echo "#endif" >>$link
- fi
+ # Include insn-codes.h last, because it includes machmode.h,
+ # and we want EXTRA_CC_MODES to be taken into account.
+ echo "#ifndef GENERATOR_FILE" >>$link
+ echo "#include \"insn-codes.h\"" >>$link
+ echo "#endif" >>$link
done
# Truncate the target if necessary