summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-12 06:31:41 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-12 06:31:41 +0000
commitaab9bda6498c0c9344edf5e5822c9f190c3d2dc0 (patch)
tree0abc7a63bf85786353fd4e9f6c5bb46a5563c504 /gcc/configure.in
parent005348abcd0412d10fdbea3fe503c494043b8e83 (diff)
downloadgcc-aab9bda6498c0c9344edf5e5822c9f190c3d2dc0.tar.gz
* configure.in: Move check for unsigned enumerated bitfields
to macro in aclocal.m4. Disable it for now. * configure, config.in: Regenerate. * system.h: Don't do anything with ONLY_INT_FIELDS. Use the unsigned-int form of ENUM_BITFIELD() unless being compiled by GCC. * varasm.c (struct rtx_const): Use ENUM_BITFIELD(). Move enum kind above its first use. * config/xm-interix.h, config/alpha/xm-alpha.h, config/i370/xm-linux.h, config/i386/xm-beos.h, config/i386/xm-mingw32.h, config/mips/xm-mips.h, config/pa/xm-pa.h, config/pa/xm-pa64hpux.h, config/rs6000/xm-beos.h, config/rs6000/xm-sysv4.h, Don't define ONLY_INT_FIELDS under any circumstances. * config/pa/xm-pa.h: Don't define __BSD_NET2__. * config/pa/xm-pahpux.h, config/pa/xm-papro.h, config/sparc/xm-sysv4.h: Delete - now identical with some other xm header. * config.gcc (hppa targets): Replace xm-pahpux.h and xm-papro.h with implicit xm-pa.h. (sparc targets): Replace xm-sysv4.h with implicit or explicit xm-sparc.h. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@40399 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in21
1 files changed, 2 insertions, 19 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 515e8c51e97..178a98c8b11 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -521,25 +521,8 @@ if test $gcc_cv_header_inttypes_h = yes; then
[Define if you have a working <inttypes.h> header file.])
fi
-#
-# Determine if enumerated bitfields are unsigned. ISO C says they can
-# be either signed or unsigned.
-#
-AC_CACHE_CHECK(for unsigned enumerated bitfields, gcc_cv_enum_bf_unsigned,
-[AC_TRY_RUN(#include <stdlib.h>
-enum t { BLAH = 128 } ;
-struct s_t { enum t member : 8; } s ;
-int main(void)
-{
- s.member = BLAH;
- if (s.member < 0) exit(1);
- exit(0);
-
-}, gcc_cv_enum_bf_unsigned=yes, gcc_cv_enum_bf_unsigned=no, gcc_cv_enum_bf_unsigned=yes)])
-if test $gcc_cv_enum_bf_unsigned = yes; then
- AC_DEFINE(ENUM_BITFIELDS_ARE_UNSIGNED, 1,
- [Define if enumerated bitfields are treated as unsigned values.])
-fi
+dnl Disabled until we have a complete test for buggy enum bitfields.
+dnl gcc_AC_C_ENUM_BF_UNSIGNED
AC_CHECK_FUNCS(strtoul bsearch putenv popen bcopy \
strchr strrchr kill getrlimit setrlimit atoll atoq \