summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-15 00:13:37 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-15 00:13:37 +0000
commit3239b2ba5f5aa18b9bf5573327614856d4bb0bc0 (patch)
treea8a2287780219d70029a474e9e7aabad07e23a65 /gcc/configure.in
parentcefc79bb0e7873e88cd0d8f73609c9c3290bdbef (diff)
downloadgcc-3239b2ba5f5aa18b9bf5573327614856d4bb0bc0.tar.gz
* aclocal.m4 (gcc_AC_C_CHARSET, gcc_AC_C_COMPILE_BIGENDIAN,
gcc_AC_C_FLOAT_FORMAT): New macros. * configure.in: Add AC_PROG_CPP after CC tests; gcc_AC_C_CHARSET and gcc_AC_C_FLOAT_FORMAT after the sizeof tests; and gcc_AC_C_COMPILE_BIGENDIAN after gcc_AC_C_CHAR_BIT. * configure, config.in: Regenerate. * config/a29k/xm-a29k.h, config/arc/xm-arc.h, config/arm/xm-arm.h, config/c4x/xm-c4x.h, config/convex/xm-convex.h, config/d30v/xm-d30v.h, config/i370/xm-linux.h, config/i370/xm-oe.h, config/ia64/xm-ia64.h, config/m32r/xm-m32r.h, config/m68k/xm-m68k.h, config/mips/xm-mips.h, config/pa/xm-linux.h, config/pa/xm-pa.h, config/rs6000/xm-lynx.h, config/rs6000/xm-mach.h, config/rs6000/xm-rs6000.h, config/rs6000/xm-sysv4.h, config/sparc/xm-sparc.h, config/vax/xm-vax.h, config/we32k/xm-we32k.h: Delete. * config/i370/xm-mvs.h, config/m88k/m88k.h, config/romp/xm-romp.h, config/rs6000/xm-beos.h, config/vax/xm-vms.h: Don't define any of: HOST_FLOAT_FORMAT, HOST_EBCDIC, HOST_WORDS_BIG_ENDIAN * config/rs6000/aix.h: Define COLLECT_EXPORT_LIST here. * config.gcc: Remove references to deleted files. (i370-*-opened*): Use i370/xm-mvs.h (which now defines only FATAL_EXIT_CODE, which is the same between oe and mvs). git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@40478 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 680a64ae263..6c9592b0b9b 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -360,6 +360,7 @@ if test $ac_cv_prog_cc_no_long_long = yes; then
fi
AC_SUBST(strict1_warn)
+AC_PROG_CPP
AC_C_INLINE
gcc_AC_C_VOLATILE
@@ -377,6 +378,9 @@ if test $ac_cv_c___int64 = yes; then
gcc_AC_COMPILE_CHECK_SIZEOF(__int64)
fi
+gcc_AC_C_CHARSET
+gcc_AC_C_FLOAT_FORMAT
+
# If the native compiler is GCC, we can enable warnings even in stage1.
# That's useful for people building cross-compilers, or just running a
# quick `make'.
@@ -458,8 +462,9 @@ AC_CHECK_HEADERS(limits.h stddef.h string.h strings.h stdlib.h time.h \
AC_CHECK_HEADER(thread.h, [have_thread_h=yes], [have_thread_h=])
AC_CHECK_HEADER(pthread.h, [have_pthread_h=yes], [have_pthread_h=])
-# This test can't be done till we know if we have limits.h.
+# These tests can't be done till we know if we have limits.h.
gcc_AC_C_CHAR_BIT
+gcc_AC_C_COMPILE_BIGENDIAN
# See if GNAT has been installed
AC_CHECK_PROG(have_gnat, gnatbind, yes, no)