summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-28 05:24:24 +0000
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-28 05:24:24 +0000
commit10be98bd87222a5f7c2a8eb07bf9ddbfd0d7f839 (patch)
treebb2aa76dca055c2e46eabf6e73ba0e455926a762 /gcc/configure.in
parente37b49973baa87e166784df747495ab2408ae0c4 (diff)
downloadgcc-10be98bd87222a5f7c2a8eb07bf9ddbfd0d7f839.tar.gz
Make -fsjlj-exceptions a configure option.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@40905 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index f22943619ac..910bf3e3446 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -1666,6 +1666,13 @@ else
fi
AC_SUBST(MAINT)dnl
+# With Setjmp/Longjmp based exception handling.
+AC_ARG_ENABLE(sjlj-exceptions,
+[ --enable-sjlj-exceptions arrange to use setjmp/longjmp exception handling.],
+[sjlj=`if test $enableval = yes; then echo 1; else echo 0; fi`
+AC_DEFINE_UNQUOTED(CONFIG_SJLJ_EXCEPTIONS, $sjlj,
+ [Define 0/1 to force the choice for exception handling model.])])
+
# Make empty files to contain the specs and options for each language.
# Then add #include lines to for a compiler that has specs and/or options.