summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authornathan <nathan@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-08 10:13:19 +0000
committernathan <nathan@138bc75d-0d04-0410-961f-82ee72b054a4>2005-05-08 10:13:19 +0000
commitfcd42b1e55fb1fb044f703eac10788ba6aa3d1d7 (patch)
tree379e548ad7e6cdc8908ed197771e9b289b60574f /gcc/configure.ac
parent4d10b46310044a21bf4a8dc66690d7080d2a88f7 (diff)
downloadgcc-fcd42b1e55fb1fb044f703eac10788ba6aa3d1d7.tar.gz
* Makefile.in (cs-tconfig.h): Pass USED_FOR_TARGET to mkconfig.sh
* aclocal.m4 (GCC_TARGET_TEMPLATE, AH_TEMPLATE): New. * configure.ac (enable_checking): Fix typos in runtime_checking. (ENABLE_RUNTIME_CHECKING): Mark as target template. (xm_file): Prepend auto-host.h (HAVE_GAS_HIDDEN, HAVE_LD_EH_FRAME_HDR): Mark as target template. * mkconfig.sh: Do not automatically define USED_FOR_TARGET in tconfig.h. * crtstuff.c: Do not include auto-host.h. (IN_LIBGCC2): Do not define. * gcov-io.h: Include tconfig.h, not auto-host.h. * libgcc2.c: Do not include auto-host.h. (abort): Do not undefine. * libgcov.c: Remove unneeded comment about config.h. * unwind-dw2-fde-glibc.c: Do not inlude auto-host.h. * config.in, configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@99386 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 21ff1fe6f03..5327e56392b 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -421,12 +421,12 @@ do
yes) ac_assert_checking=1 ; ac_checking=1 ;
ac_fold_checking= ; ac_gc_checking=1 ;
ac_gc_always_collect= ; ac_rtl_checking= ;
- ac_rtlflag_checking=1 ; ac_runtime_chacking=1 ;
+ ac_rtlflag_checking=1 ; ac_runtime_checking=1 ;
ac_tree_checking=1 ; ac_valgrind_checking= ;;
no|none) ac_assert_checking= ; ac_checking= ;
ac_fold_checking= ; ac_gc_checking= ;
ac_gc_always_collect= ; ac_rtl_checking= ;
- ac_rtlflag_checking= ; ac_runtime_chacking= ;
+ ac_rtlflag_checking= ; ac_runtime_checking= ;
ac_tree_checking= ; ac_valgrind_checking= ;;
all) ac_assert_checking=1 ; ac_checking=1 ;
ac_fold_checking=1 ; ac_gc_checking=1 ;
@@ -466,6 +466,7 @@ if test x$ac_assert_checking != x ; then
AC_DEFINE(ENABLE_ASSERT_CHECKING, 1,
[Define if you want assertions enabled. This is a cheap check.])
fi
+GCC_TARGET_TEMPLATE(ENABLE_RUNTIME_CHECKING)
if test x$ac_runtime_checking != x ; then
AC_DEFINE(ENABLE_RUNTIME_CHECKING, 1,
[Define if you want runtime assertions enabled. This is a cheap check.])
@@ -1402,7 +1403,7 @@ host_xm_file="auto-host.h ansidecl.h ${host_xm_file}"
build_xm_file="${build_auto} ansidecl.h ${build_xm_file}"
# We don't want ansidecl.h in target files, write code there in ISO/GNU C.
# put this back in temporarily.
-xm_file="ansidecl.h ${xm_file}"
+xm_file="auto-host.h ansidecl.h ${xm_file}"
# --------
# UNSORTED
@@ -2140,6 +2141,7 @@ changequote([,])dnl
fi])
libgcc_visibility=no
AC_SUBST(libgcc_visibility)
+GCC_TARGET_TEMPLATE([HAVE_GAS_HIDDEN])
if test $gcc_cv_as_hidden = yes && test $gcc_cv_ld_hidden = yes; then
libgcc_visibility=yes
AC_DEFINE(HAVE_GAS_HIDDEN, 1,
@@ -2951,6 +2953,7 @@ elif test x$gcc_cv_ld != x; then
gcc_cv_ld_eh_frame_hdr=yes
fi
fi
+GCC_TARGET_TEMPLATE([HAVE_LD_EH_FRAME_HDR])
if test x"$gcc_cv_ld_eh_frame_hdr" = xyes; then
AC_DEFINE(HAVE_LD_EH_FRAME_HDR, 1,
[Define if your linker supports --eh-frame-hdr option.])