summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2006-02-14 16:46:04 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2006-02-14 16:46:04 +0000
commitf3424fe63fb30896267cd3d2ee562399740112b2 (patch)
tree86e362d4961edcd25e436ff9c4a4606a4202be29 /gcc/configure.ac
parent764f11758d254e1dee25b04620786ef89ad6ccce (diff)
downloadgcc-f3424fe63fb30896267cd3d2ee562399740112b2.tar.gz
PR bootstrap/26053
* configure.ac (HAVE_COMDAT_GROUP): Don't assume non-GNU linkers support COMDAT group. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@110985 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 7d7655e7cc4..3c597badfa6 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2245,10 +2245,13 @@ if test $in_tree_ld != yes && test x"$ld_vers" != x; then
comdat_group=no
fi
fi
- if test $comdat_group = no; then
- gcc_cv_as_comdat_group=no
- gcc_cv_as_comdat_group_percent=no
- fi
+else
+ # assume linkers other than GNU ld don't support COMDAT group
+ comdat_group=no
+fi
+if test $comdat_group = no; then
+ gcc_cv_as_comdat_group=no
+ gcc_cv_as_comdat_group_percent=no
fi
AC_DEFINE_UNQUOTED(HAVE_COMDAT_GROUP,
[`if test $gcc_cv_as_comdat_group = yes || test $gcc_cv_as_comdat_group_percent = yes; then echo 1; else echo 0; fi`],