summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorMichael Matz <matz@gcc.gnu.org>2011-11-03 17:17:07 +0000
committerMichael Matz <matz@gcc.gnu.org>2011-11-03 17:17:07 +0000
commite941124721742b4972785960645a57178fabb71c (patch)
tree4343503ebcbfe34ff7e06478572708b57fff1bf4 /gcc/configure.ac
parentaf8d2409beff727cf7d29025c09abded080d4cf7 (diff)
downloadgcc-e941124721742b4972785960645a57178fabb71c.tar.gz
re PR bootstrap/50857 (The compiler is built with exceptions and RTTI enabled)
libcpp/ PR bootstrap/50857 * configure.ac: Check for -fno-exceptions -fno-rtti. * configure: Regenerate. * Makefile.in (NOEXCEPTION_FLAGS): New flag. (ALL_CXXFLAGS): Use it. gcc/ PR bootstrap/50857 * configure.ac: Check for -fno-exceptions -fno-rtti. * configure: Regenerate. * Makefile.in (NOEXCEPTION_FLAGS): New flag. (ALL_CXXFLAGS): Use it. From-SVN: r180833
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 9196996aedf..c7654259c4a 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -358,6 +358,10 @@ fi
AC_SUBST(warn_cflags)
AC_SUBST(warn_cxxflags)
+# Disable exceptions and RTTI if building with g++
+ACX_PROG_CC_WARNING_OPTS(
+ m4_quote(m4_do([-fno-exceptions -fno-rtti])), [noexception_flags])
+
# Enable expensive internal checks
is_release=
if test x"`cat $srcdir/DEV-PHASE`" != xexperimental; then