summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorRoger Sayle <roger@eyesopen.com>2004-11-25 01:41:20 +0000
committerRoger Sayle <sayle@gcc.gnu.org>2004-11-25 01:41:20 +0000
commit2102b2fe72df5d96409d2f7b0a9a6d6b702598e3 (patch)
tree4519bae1413cb73435638cd79cae7b6576032213 /gcc/configure.ac
parenta26e9a2687a922bc0eaee597fbed34d34733b228 (diff)
downloadgcc-2102b2fe72df5d96409d2f7b0a9a6d6b702598e3.tar.gz
configure.ac: Tweak test for HAVE_DECL_LDGETNAME to avoid a system header conflict on AIX 5.2.
* configure.ac: Tweak test for HAVE_DECL_LDGETNAME to avoid a system header conflict on AIX 5.2. * configure: Regenerate. From-SVN: r91266
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 80eb7161ca8..c7e49c0fc45 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1053,10 +1053,16 @@ AC_TRY_COMPILE([
],[rlim_t l = 0;],,[AC_DEFINE([rlim_t],[long],
[Define to \`long' if <sys/resource.h> doesn't define.])])
+# On AIX 5.2, <ldfcn.h> conflicts with <fcntl.h>, as both define incompatible
+# FREAD and FWRITE macros. Fortunately, for GCC's single usage of ldgetname
+# in collect2.c, <fcntl.h> isn't visible, but the configure test below needs
+# to undef these macros to get the correct value for HAVE_DECL_LDGETNAME.
gcc_AC_CHECK_DECLS(ldgetname, , ,[
#include "ansidecl.h"
#include "system.h"
#ifdef HAVE_LDFCN_H
+#undef FREAD
+#undef FWRITE
#include <ldfcn.h>
#endif
])